CVE-2024-36522
Apache Wicket: Remote code execution via XSLT injection
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Apache Wicket: Remote code execution via XSLT injection
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
- Record
CVE-2024-36522- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
EUVDEUVD-2024-2364
9.8
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
- Record
EUVD-2024-2364- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-hhwc-gh8h-9rrp No score
Apache Wicket: Remote code execution via XSLT injection
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
- Record
GHSA-hhwc-gh8h-9rrp- Weakness
- CWE-74
- Updated
- 2026-11-02
NVD
9.8
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
- Record
CVE-2024-36522- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
OSV
9.8
Apache Wicket: Remote code execution via XSLT injection
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
- Record
CVE-2024-36522- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-74
- Updated
- 2026-11-02
OSVGHSA-hhwc-gh8h-9rrp No score
Apache Wicket: Remote code execution via XSLT injection
The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.
- Record
GHSA-hhwc-gh8h-9rrp- Weakness
- CWE-74
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.wicket:wicket-utilMaven |
10.0.0-M1 up to 10.1.0 | 10.1.0 |
org.apache.wicket:wicket-utilMaven |
9.0.0 up to 9.18.0 | 9.18.0 |
org.apache.wicket:wicket-utilMaven |
8.0.0 up to 8.16.0 | 8.16.0 |
org.apache.wicket:wicket-utilMaven |
10.0.0-M1 up to 10.1.0, plus listed versions 10.0.010.0.0-M2 |
10.1.0 |
org.apache.wicket:wicket-utilMaven |
9.0.0 up to 9.18.0, plus listed versions 9.1.09.10.09.11.09.12.09.13.0 Show 13 moreShow less9.14.09.15.09.16.09.17.09.2.09.3.09.4.09.5.09.6.09.7.09.8.09.9.09.9.1 |
9.18.0 |
org.apache.wicket:wicket-utilMaven |
8.0.0 up to 8.16.0, plus listed versions 8.1.08.10.08.11.08.12.08.13.0 Show 11 moreShow less8.14.08.15.08.2.08.3.08.4.08.5.08.6.08.6.18.7.08.8.08.9.0 |
8.16.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-36522 is a critical vulnerability (CVSS 9.8) in Apache Wicket, published July 12, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.13%, the 81st percentile. Fixed in org.apache.wicket:wicket-util 10.1.0.
References
lists.apache.org/thread/w613qh7yors840pbx00l1pq6wkl9jzkc
openwall.com/lists/oss-security/2024/07/12/2
nvd.nist.gov/vuln/detail/CVE-2024-36522
github.com/advisories/GHSA-hhwc-gh8h-9rrp
repo.maven.apache.org/maven2
github.com/CVEProject/cvelistV5/tree/main/cves/2024/36xxx/CVE-2024-36522.json
github.com/apache/wicket