Every CVE Search/ Get API key

CVE-2024-37055

MLFlow unsafe deserialization

8.8 HighFix available

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.62%Up 0.6 points since Jun 5, 2024
90%50%10%1%

What each source reports

CVE List Score used 8.8

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
CVE-2024-37055
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
EUVDEUVD-2024-2203 8.8

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
EUVD-2024-2203
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-x38x-g6gr-jqff 8.8

MLFlow unsafe deserialization

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
GHSA-x38x-g6gr-jqff
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
NVD 8.8

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
CVE-2024-37055
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVGHSA-x38x-g6gr-jqff 8.8

MLFlow unsafe deserialization

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
GHSA-x38x-g6gr-jqff
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVPYSEC-2026-1663 8.8

MLFlow unsafe deserialization

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
PYSEC-2026-1663
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-mlflow-2024-37055 No score

Deserialization of untrusted data can occur in versions of the MLflow platform running version 1.24.0 or newer, enabling a maliciously uploaded pmdarima model to run arbitrary code on an end user’s system when interacted with.

Record
BIT-mlflow-2024-37055
Updated
2026-11-02
OSVCLSA-2026-1780879892 No score

TuxCare security update for mlflow (5 CVEs)

TuxCare rebuilt mlflow to address 5 CVEs. Fixed in 2.9.1.post4+tuxcare.

Record
CLSA-2026-1780879892
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mlflow
PyPI
1.24.0 to 2.14.1 None known
mlflow
Bitnami
1.24.0 up to 2.14.2
2.14.2
mlflow
TuxCare:PyPI
From an advisory covering 5 CVEs
2.9.1 up to 2.9.1.post4+tuxcare, plus listed versions
2.9.1.post1+tuxcare2.9.1.post2+tuxcare2.9.1.post3+tuxcare
2.9.1.post4+tuxcare
mlflow
PyPI
1.24.0 to 2.14.1, plus listed versions
1.25.01.25.11.26.01.26.11.27.0
Show 43 moreShow less
1.28.01.29.01.30.01.30.12.0.02.0.0rc02.0.12.1.02.1.12.10.02.10.12.10.22.11.02.11.12.11.22.11.32.11.42.12.02.12.12.12.22.13.02.13.12.13.22.14.02.14.0rc02.2.02.2.12.2.22.3.02.3.12.3.22.4.02.4.12.4.22.5.02.6.02.7.02.7.12.8.02.8.12.9.02.9.12.9.2
None known

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-37055 is a high vulnerability (CVSS 8.8) in Lfprojects Mlflow, published June 4, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 50th percentile. Fixed in mlflow 2.14.2.

References

MoveEnter Open