Every CVE Search/ Get API key

CVE-2024-38276

moodle: CSRF risks due to misuse of confirm_sesskey

8.8 HighFix available

Incorrect CSRF token checks resulted in multiple CSRF risks.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.46%Up 0.4 points since Jun 19, 2024
90%50%10%1%

What each source reports

NVD Score used 8.8

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
CVE-2024-38276
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
CVE List 8.8

moodle: CSRF risks due to misuse of confirm_sesskey

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
CVE-2024-38276
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
EUVDEUVD-2024-1895 8.8

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
EUVD-2024-1895
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-356g-7x36-7m34 5.3

Moodle CSRF risks due to misuse of confirm_sesskey

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
GHSA-356g-7x36-7m34
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
OSV 8.8

moodle: CSRF risks due to misuse of confirm_sesskey

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
CVE-2024-38276
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-356g-7x36-7m34 5.3

Moodle CSRF risks due to misuse of confirm_sesskey

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
GHSA-356g-7x36-7m34
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weakness
CWE-352
Updated
2026-11-02
OSVUBUNTU-CVE-2024-38276 8.8

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
UBUNTU-CVE-2024-38276
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-moodle-2024-38276 No score

moodle: CSRF risks due to misuse of confirm_sesskey

Incorrect CSRF token checks resulted in multiple CSRF risks.

Record
BIT-moodle-2024-38276
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
4.4.0-beta up to 4.4.1
4.4.1
moodle/moodle
Packagist
4.3.0-beta up to 4.3.5
4.3.5
moodle/moodle
Packagist
4.2.0-beta up to 4.2.8
4.2.8
moodle/moodle
Packagist
before 4.1.11
4.1.11
moodle
Bitnami
before 4.1.10, 4.2.0 up to 4.2.8, 4.3.0 up to 4.3.5, 4.4.0 up to 4.4.1
4.1.104.2.84.3.54.4.1
moodle/moodle
Packagist
4.4.0-beta up to 4.4.1, plus listed versions
v4.4.0v4.4.0-betav4.4.0-rc1v4.4.0-rc2
4.4.1
moodle/moodle
Packagist
4.3.0-beta up to 4.3.5, plus listed versions
v4.3.0v4.3.0-betav4.3.0-rc1v4.3.0-rc2v4.3.1v4.3.2v4.3.3v4.3.4
4.3.5
moodle/moodle
Packagist
4.2.0-beta up to 4.2.8, plus listed versions
v4.2.0v4.2.0-betav4.2.0-rc1v4.2.0-rc2v4.2.1
Show 6 moreShow less
v4.2.2v4.2.3v4.2.4v4.2.5v4.2.6v4.2.7
4.2.8
moodle/moodle
Packagist
before 4.1.11, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.1.11
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-38276 is a high vulnerability (CVSS 8.8) in Moodle, published June 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 40th percentile. Fixed in moodle/moodle 4.4.1.

References

Show 19 moreShow less
This page doesn't list everything

Left out here: 293 versions. The JSON record has them.

MoveEnter Open