Every CVE Search/ Get API key

CVE-2024-38448

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is...

9.1 CriticalFix available

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.53%Up 0.5 points since Jun 17, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.1

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
CVE-2024-38448
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2024-37337 9.1

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
EUVD-2024-37337
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-j4rp-pq8q-wm7r 9.1

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is...

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
GHSA-j4rp-pq8q-wm7r
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-94
Updated
2026-11-02
NVD 9.1

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
CVE-2024-38448
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-94
Updated
2026-11-02
OSVDEBIAN-CVE-2024-38448 9.1

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
DEBIAN-CVE-2024-38448
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2024-38448 9.1

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
UBUNTU-CVE-2024-38448
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSV No score

htags in GNU Global through 6.6.12 allows code execution in situations where dbpath (aka -d) is untrusted, because shell metacharacters may be used.

Record
CVE-2024-38448
Updated
2026-11-02
OSVopenSUSE-SU-2024:0210-1 No score

Security update for global

This update for global fixes the following issues:

  • CVE-2024-38448: htags may allow code execution via untrusted dbpath (boo#1226420)
Record
openSUSE-SU-2024:0210-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:14123-1 No score

global-6.6.13-1.1 on GA media

These are all security issues fixed in the global-6.6.13-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14123-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
global
Debian:12
All versions, plus listed versions
6.6.11-16.6.12-16.6.13-16.6.14-16.6.14-1.16.6.9-1
None known
global
Debian:13
before 6.6.13-1
6.6.13-1
global
Debian:14
before 6.6.13-1
6.6.13-1
global
Ubuntu:16.04:LTS
All versions, plus listed versions
5.7.1-2
None known
global
Ubuntu:18.04:LTS
All versions, plus listed versions
6.5.7-16.5.7-46.6.1-16.6.2-1
None known
global
Ubuntu:20.04:LTS
All versions, plus listed versions
6.6.3-26.6.3-36.6.4-1
None known
global
Ubuntu:22.04:LTS
All versions, plus listed versions
6.6.5-16.6.7-1
None known
global
Ubuntu:24.04:LTS
All versions, plus listed versions
6.6.9-16.6.11-1
None known
global
Ubuntu:25.10
All versions, plus listed versions
6.6.13-16.6.14-1.1
None known
global
Ubuntu:26.10
All versions, plus listed versions
6.6.14-1.1build1
None known
Show 6 moreShow less
Affected packages
PackageAffectedFixed
global
Ubuntu:26.04:LTS
All versions, plus listed versions
6.6.14-1.16.6.14-1.1build1
None known
global
SUSE:Package Hub 15 SP5
before 6.6.9-bp156.3.3.1
6.6.9-bp156.3.3.1
global
SUSE:Package Hub 15 SP6
before 6.6.9-bp156.3.3.1
6.6.9-bp156.3.3.1
global
openSUSE:Leap 15.5
before 6.6.9-bp156.3.3.1
6.6.9-bp156.3.3.1
global
openSUSE:Leap 15.6
before 6.6.9-bp156.3.3.1
6.6.9-bp156.3.3.1
global
openSUSE:Tumbleweed
before 6.6.13-1.1
6.6.13-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-38448 is a critical vulnerability (CVSS 9.1) in Gnu Global, published June 16, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in global 6.6.13-1.

References

Show 4 moreShow less
MoveEnter Open