Every CVE Search/ Get API key

CVE-2024-39124

Roundup Cross-site Scripting Vulnerability

5.4 MediumFix available

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.29%Up 0.2 points since Jul 18, 2024
90%50%10%1%

What each source reports

NVD Score used 5.4

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
CVE-2024-39124
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List 6.1

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
CVE-2024-39124
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-0157 6.1

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
EUVD-2024-0157
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-w8vc-cwv9-wx67 5.3

Roundup Cross-site Scripting Vulnerability

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
GHSA-w8vc-cwv9-wx67
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-w8vc-cwv9-wx67 5.3

Roundup Cross-site Scripting Vulnerability

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
GHSA-w8vc-cwv9-wx67
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2024-39124 6.1

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
UBUNTU-CVE-2024-39124
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVPYSEC-2024-63 No score

In Roundup before 2.4.0, classhelpers (_generic.help.html) allow XSS.

Record
PYSEC-2024-63
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
roundup
PyPI
before 2.4.0
2.4.0
roundup
PyPI
before 2.4.0, plus listed versions
0.5.90.6.110.6.80.6.90.7.0
Show 45 moreShow less
0.7.0b30.7.10.7.110.7.120.7.20.7.30.7.40.7.50.7.70.7.80.7.90.8.00.8.0b10.8.10.8.20.8.30.8.40.8.50.8.60.9.0b11.01.0.11.1.01.1.11.1.21.2.01.2.11.3.01.3.11.3.21.3.31.4.01.4.11.4.101.4.111.4.121.4.131.4.141.4.151.4.161.4.171.4.181.4.191.4.21.4.20
2.4.0
roundup
Ubuntu:16.04:LTS
All versions, plus listed versions
1.4.20-1.11.4.20-1.1+deb8u1build0.16.04.11.4.20-1.1+deb8u2build0.16.04.1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-39124 is a medium vulnerability (CVSS 5.4) in Roundup-tracker Roundup, published July 17, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in roundup 2.4.0.

References

This page doesn't list everything

Left out here: 23 versions. The JSON record has them.

MoveEnter Open