CVE-2024-4215
The Multi Factor Authentication bypass vulnerability in pgAdmin 4
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
7.4
The Multi Factor Authentication bypass vulnerability in pgAdmin 4
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
CVE-2024-4215- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Weakness
- CWE-89
- Updated
- 2026-11-02
EUVDEUVD-2024-1364
7.4
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
EUVD-2024-1364- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-2mvc-557g-5638
5.3
pgAdmin is affected by a multi-factor authentication bypass vulnerability
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
GHSA-2mvc-557g-5638- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L - CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Weakness
- CWE-89
- Updated
- 2026-11-02
NVD
7.4
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
CVE-2024-4215- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
7.4
The Multi Factor Authentication bypass vulnerability in pgAdmin 4
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
CVE-2024-4215- CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
OSVGHSA-2mvc-557g-5638
5.3
pgAdmin is affected by a multi-factor authentication bypass vulnerability
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
GHSA-2mvc-557g-5638- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L - CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVPYSEC-2026-1768
5.3
pgAdmin is affected by a multi-factor authentication bypass vulnerability
pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.
- Record
PYSEC-2026-1768- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L - CVSS 3.1
- 7.4 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:14052-1 No score
pgadmin4-8.8-1.1 on GA media
These are all security issues fixed in the pgadmin4-8.8-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:14052-1- Updated
- 2026-11-02
OSVSUSE-SU-2024:2260-1 No score
Security update for pgadmin4
This update for pgadmin4 fixes the following issues:
- CVE-2024-4216: Fixed XSS in /settings/store endpoint (bsc#1223868).
- CVE-2024-4215: Fixed multi-factor authentication bypass (bsc#1223867).
- Record
SUSE-SU-2024:2260-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pgadmin4PyPI |
through 8.5 | 8.6 |
pgadmin4PyPI |
before 8.6, plus listed versions 4.204.224.234.244.25 Show 45 moreShow less4.264.274.284.294.305.05.15.25.35.45.55.65.76.106.116.126.136.146.156.166.176.186.196.26.206.216.36.46.56.66.76.86.97.07.17.27.37.47.57.67.77.88.08.18.2 |
8.6 |
pgadmin4SUSE:Linux Enterprise Module for Python 3 15 SP6 From an advisory covering 2 CVEs |
before 8.5-150600.3.3.1 | 8.5-150600.3.3.1 |
pgadmin4openSUSE:Leap 15.6 From an advisory covering 2 CVEs |
before 8.5-150600.3.3.1 | 8.5-150600.3.3.1 |
pgadmin4openSUSE:Tumbleweed From an advisory covering 2 CVEs |
before 8.8-1.1 | 8.8-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-4215 is a high vulnerability (CVSS 7.4) in Pgadmin 4, published May 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.63%, the 50th percentile. Fixed in pgadmin4 8.6.
References
github.com/pgadmin-org/pgadmin4/issues/7425
lists.fedoraproject.org/archives/list/[email protected]/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE
nvd.nist.gov/vuln/detail/CVE-2024-4215
github.com/pgadmin-org/pgadmin4/commit/f4761f55f7cf6d56d6c5129f921393b0b47fd976
github.com/advisories/GHSA-2mvc-557g-5638
github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4215.json
Left out here: 3 versions. The JSON record has them.