Every CVE Search/ Get API key

CVE-2024-4216

XSS vulnerability in /settings/store API response json payload in pgAdmin 4

7.4 HighFix available

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.46%Up 0.4 points since May 3, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.4

XSS vulnerability in /settings/store API response json payload in pgAdmin 4

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
CVE-2024-4216
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-1871 7.4

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
EUVD-2024-1871
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-xv64-8p4r-94gq 7.4

pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
GHSA-xv64-8p4r-94gq
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
NVD 7.4

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
CVE-2024-4216
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 7.4

XSS vulnerability in /settings/store API response json payload in pgAdmin 4

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
CVE-2024-4216
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-02
OSVGHSA-xv64-8p4r-94gq 7.4

pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
GHSA-xv64-8p4r-94gq
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
Show 4 moreShow less
OSVPYSEC-2026-1777 7.4

pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload

pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.

Record
PYSEC-2026-1777
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2024:14052-1 No score

pgadmin4-8.8-1.1 on GA media

These are all security issues fixed in the pgadmin4-8.8-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14052-1
Updated
2026-11-02
OSVSUSE-SU-2024:2260-1 No score

Security update for pgadmin4

This update for pgadmin4 fixes the following issues:

  • CVE-2024-4216: Fixed XSS in /settings/store endpoint (bsc#1223868).
  • CVE-2024-4215: Fixed multi-factor authentication bypass (bsc#1223867).
Record
SUSE-SU-2024:2260-1
Updated
2026-11-02
OSVSUSE-SU-2024:3552-1 No score

Security update for pgadmin4

This update for pgadmin4 fixes the following issues:

  • CVE-2024-4216: Fixed XSS in /settings/store endpoint (bsc#1223868)
Record
SUSE-SU-2024:3552-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgadmin4
PyPI
through 8.5
8.6
pgadmin4
PyPI
before 8.6, plus listed versions
4.204.224.234.244.25
Show 45 moreShow less
4.264.274.284.294.305.05.15.25.35.45.55.65.76.106.116.126.136.146.156.166.176.186.196.26.206.216.36.46.56.66.76.86.97.07.17.27.37.47.57.67.77.88.08.18.2
8.6
pgadmin4
SUSE:Linux Enterprise Module for Python 3 15 SP6
From an advisory covering 2 CVEs
before 8.5-150600.3.3.1
8.5-150600.3.3.1
pgadmin4
openSUSE:Leap 15.6
From an advisory covering 2 CVEs
before 8.5-150600.3.3.1
8.5-150600.3.3.1
pgadmin4
SUSE:Linux Enterprise Module for Python 3 15 SP6
before 4.30-150300.3.15.1
4.30-150300.3.15.1
pgadmin4
SUSE:Linux Enterprise Module for Server Applications 15 SP5
before 4.30-150300.3.15.1
4.30-150300.3.15.1
pgadmin4
openSUSE:Leap 15.5
before 4.30-150300.3.15.1
4.30-150300.3.15.1
pgadmin4
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 8.8-1.1
8.8-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-4216 is a high vulnerability (CVSS 7.4) in Pgadmin 4, published May 2, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.46%, the 40th percentile. Fixed in pgadmin4 8.6.

References

Show 8 moreShow less
This page doesn't list everything

Left out here: 3 versions. The JSON record has them.

MoveEnter Open