Every CVE Search/ Get API key

CVE-2024-4311

Lack of login attempt rate-limiting in zenml-io/zenml

5.4 MediumFix available

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
None
Availability
High

Exploit likelihood

0.51%Up 0.5 points since Nov 15, 2024
90%50%10%1%

What each source reports

CVE List 5.4

Lack of login attempt rate-limiting in zenml-io/zenml

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
CVE-2024-4311
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
EUVDEUVD-2024-3270 5.4

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
EUVD-2024-3270
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-j3vq-pmp5-r5xj 5.4

Missing ratelimit on passwrod resets in zenml

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
GHSA-j3vq-pmp5-r5xj
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
NVD 5.4

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
CVE-2024-4311
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
CVSS 3.0
5.4 MediumCVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
OSV 5.4

Lack of login attempt rate-limiting in zenml-io/zenml

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
CVE-2024-4311
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
OSVGHSA-j3vq-pmp5-r5xj 5.4

Missing ratelimit on passwrod resets in zenml

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
GHSA-j3vq-pmp5-r5xj
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Weakness
CWE-770
Updated
2026-11-02
OSVPYSEC-2026-2070 5.4

Missing ratelimit on passwrod resets in zenml

zenml-io/zenml version 0.56.4 is vulnerable to an account takeover due to the lack of rate-limiting in the password change function. An attacker can brute-force the current password in the 'Update Password' function, allowing them to take over the user's account. This vulnerability is due to the absence of rate-limiting on the '/api/v1/current-user' endpoint, which does not restrict the number of attempts an attacker can make to guess the current password. Successful exploitation results in the attacker being able to change the password and take control of the account.

Record
PYSEC-2026-2070
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zenml
PyPI
before 0.57.0rc2
0.57.0rc2
zenml
PyPI
before 0.57.0rc2, plus listed versions
0.0.1rc10.0.1rc20.1.00.1.10.1.2
Show 45 moreShow less
0.1.30.1.3rc00.1.40.1.50.10.00.11.00.12.00.13.00.13.10.13.20.2.00.2.0rc10.2.0rc20.20.00.20.0rc10.20.10.20.20.20.30.20.40.20.50.21.00.21.10.22.00.23.00.3.10.3.1rc00.3.20.3.30.3.3rc00.3.40.3.4rc00.3.50.3.5rc00.3.60.3.6.10.3.6rc00.3.70.3.7.1rc00.3.7.1rc10.3.7.1rc30.3.7.1rc40.3.7rc00.3.80.3.9rc10.3.9rc2
0.57.0rc2

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-4311 is a medium vulnerability (CVSS 5.4) in Zenml, published November 14, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in zenml 0.57.0rc2.

References

This page doesn't list everything

Left out here: 85 versions. The JSON record has them.

MoveEnter Open