Every CVE Search/ Get API key

CVE-2024-43425

Moodle: remote code execution via calculated question types

8.1 HighPublic exploitFix available

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

87.5%Up 87.5 points since Nov 8, 2024
90%50%10%1%

What each source reports

CVE List Score used 8.1

Moodle: remote code execution via calculated question types

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
CVE-2024-43425
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
EUVDEUVD-2024-3314 8.1

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
EUVD-2024-3314
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-v6f4-v8h8-3c87 7.2

Moodle Remote Code Execution vulnerability

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
GHSA-v6f4-v8h8-3c87
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
NVD 8.1

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
CVE-2024-43425
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSV 8.1

Moodle: remote code execution via calculated question types

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
CVE-2024-43425
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-v6f4-v8h8-3c87 7.2

Moodle Remote Code Execution vulnerability

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
GHSA-v6f4-v8h8-3c87
CVSS 4.0
7.2 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-94
Updated
2026-11-02
OSVUBUNTU-CVE-2024-43425 8.1

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
UBUNTU-CVE-2024-43425
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVBIT-moodle-2024-43425 No score

Moodle: remote code execution via calculated question types

A flaw was found in Moodle. Additional restrictions are required to avoid a remote code execution risk in calculated question types. Note: This requires the capability to add/update questions.

Record
BIT-moodle-2024-43425
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 4.1.12
4.1.12
moodle/moodle
Packagist
4.2.0-beta up to 4.2.9
4.2.9
moodle/moodle
Packagist
4.3.0-beta up to 4.3.6
4.3.6
moodle/moodle
Packagist
4.4.0-beta up to 4.4.2
4.4.2
moodle
Bitnami
before 4.1.12, 4.2.0 up to 4.2.9, 4.3.0 up to 4.3.6, 4.4.0 up to 4.4.2
4.1.124.2.94.3.64.4.2
moodle/moodle
Packagist
before 4.1.12, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.1.12
moodle/moodle
Packagist
4.2.0-beta up to 4.2.9, plus listed versions
v4.2.0v4.2.0-betav4.2.0-rc1v4.2.0-rc2v4.2.1
Show 7 moreShow less
v4.2.2v4.2.3v4.2.4v4.2.5v4.2.6v4.2.7v4.2.8
4.2.9
moodle/moodle
Packagist
4.3.0-beta up to 4.3.6, plus listed versions
v4.3.0v4.3.0-betav4.3.0-rc1v4.3.0-rc2v4.3.1
Show 4 moreShow less
v4.3.2v4.3.3v4.3.4v4.3.5
4.3.6
moodle/moodle
Packagist
4.4.0-beta up to 4.4.2, plus listed versions
v4.4.0v4.4.0-betav4.4.0-rc1v4.4.0-rc2v4.4.1
4.4.2
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-43425 is a high vulnerability (CVSS 8.1) in Moodle, published November 7, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 87.5%, the 99th percentile. Fixed in moodle/moodle 4.1.12.

References

This page doesn't list everything

Left out here: 294 versions. The JSON record has them.

MoveEnter Open