Every CVE Search/ Get API key

CVE-2024-43430

Moodle: lack of access control when using external methods for quiz overrides

5.3 MediumFix available

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.33%Up 0.3 points since Nov 12, 2024
90%50%10%1%

What each source reports

CVE List Score used 5.3

Moodle: lack of access control when using external methods for quiz overrides

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
CVE-2024-43430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-276
Updated
2026-11-02
EUVDEUVD-2024-3275 5.3

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
EUVD-2024-3275
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-jpf2-9ppp-2c49 2.7

Moodle has insufficient access control

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
GHSA-jpf2-9ppp-2c49
CVSS 4.0
2.7 LowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-276
Updated
2026-11-02
NVD 5.3

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
CVE-2024-43430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-276
Updated
2026-11-02
OSV 5.3

Moodle: lack of access control when using external methods for quiz overrides

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
CVE-2024-43430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVGHSA-jpf2-9ppp-2c49 2.7

Moodle has insufficient access control

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
GHSA-jpf2-9ppp-2c49
CVSS 4.0
2.7 LowCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-276
Updated
2026-11-02
OSVUBUNTU-CVE-2024-43430 5.3

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
UBUNTU-CVE-2024-43430
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVBIT-moodle-2024-43430 No score

Moodle: lack of access control when using external methods for quiz overrides

A flaw was found in moodle. External API access to Quiz can override contained insufficient access control.

Record
BIT-moodle-2024-43430
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
4.4.0 up to 4.4.2
4.4.2
moodle
Bitnami
4.4.0 up to 4.4.2
4.4.2
moodle/moodle
Packagist
4.4.0 up to 4.4.2, plus listed versions
v4.4.0v4.4.1
4.4.2
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-43430 is a medium vulnerability (CVSS 5.3) in Moodle, published November 11, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 25th percentile. Fixed in moodle/moodle 4.4.2.

References

MoveEnter Open