CVE-2024-43598
LightGBM Remote Code Execution Vulnerability
LightGBM Remote Code Execution Vulnerability
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
LightGBM Remote Code Execution Vulnerability
LightGBM Remote Code Execution Vulnerability
- Record
CVE-2024-43598- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C - Weakness
- CWE-122
- Updated
- 2026-11-04
EUVDEUVD-2024-40349
8.1
LightGBM Remote Code Execution Vulnerability
- Record
EUVD-2024-40349- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C - Updated
- 2026-11-04
GitHub AdvisoriesGHSA-2586-f3p4-hq84
7.1
LightGBM Remote Code Execution Vulnerability
LightGBM Remote Code Execution Vulnerability
- Record
GHSA-2586-f3p4-hq84- CVSS 3.1
- 7.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C - Weakness
- CWE-122
- Updated
- 2026-11-02
NVD
8.1
LightGBM Remote Code Execution Vulnerability
- Record
CVE-2024-43598- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-122
- Updated
- 2026-11-04
OSVGHSA-2586-f3p4-hq84
8.1
LightGBM Remote Code Execution Vulnerability
LightGBM Remote Code Execution Vulnerability
- Record
GHSA-2586-f3p4-hq84- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C - Weakness
- CWE-122
- Updated
- 2026-11-02
OSVPYSEC-2024-231
8.1
LightGBM Remote Code Execution Vulnerability
- Record
PYSEC-2024-231- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVCLSA-2026-1776904627 No score
TuxCare security update for lightgbm (1 CVE)
TuxCare rebuilt lightgbm to address 1 CVE. Fixed in 3.3.5.post1+tuxcare.
- Record
CLSA-2026-1776904627- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lightgbmPyPI |
1.0.0 up to 4.6.0 | 4.6.0 |
lightgbmTuxCare:PyPI |
3.3.5 up to 3.3.5.post1+tuxcare | 3.3.5.post1+tuxcare |
lightgbmPyPI |
1.0.0 up to 4.6.0, plus listed versions 2.0.102.0.112.0.122.0.22.0.3 Show 31 moreShow less2.0.42.0.52.0.62.0.72.1.02.1.12.1.22.2.02.2.12.2.22.2.32.3.02.3.13.0.03.0.0rc13.1.03.1.13.2.03.2.13.3.03.3.13.3.23.3.33.3.43.3.54.0.04.1.04.2.04.3.04.4.04.5.0 |
4.6.0 |
lightgbmPyPI |
before 4.6.0, plus listed versions 2.0.102.0.112.0.122.0.22.0.3 Show 31 moreShow less2.0.42.0.52.0.62.0.72.1.02.1.12.1.22.2.02.2.12.2.22.2.32.3.02.3.13.0.03.0.0rc13.1.03.1.13.2.03.2.13.3.03.3.13.3.23.3.33.3.43.3.54.0.04.1.04.2.04.3.04.4.04.5.0 |
4.6.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | CVE List, EUVD | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-43598 is a high vulnerability (CVSS 8.1) in Microsoft Lightgbm, published November 12, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in lightgbm 4.6.0.