CVE-2024-44314
TastyIgniter Has an Incorrect Access Control Vulnerability
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.5
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
- Record
CVE-2024-44314- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2024-54087
6.5
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
- Record
EUVD-2024-54087- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-w5h7-mw56-4v7x
6.5
TastyIgniter Has an Incorrect Access Control Vulnerability
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
- Record
GHSA-w5h7-mw56-4v7x- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
NVD
6.5
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
- Record
CVE-2024-44314- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
6.5
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
- Record
CVE-2024-44314- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-w5h7-mw56-4v7x
6.5
TastyIgniter Has an Incorrect Access Control Vulnerability
TastyIgniter 3.7.6 contains an Incorrect Access Control vulnerability in the Orders Management System, allowing unauthorized users to update order statuses. The issue occurs in the index_onUpdateStatus() function within Orders.php, which fails to verify if the user has permission to modify an order's status. This flaw can be exploited remotely, leading to unauthorized order manipulation.
- Record
GHSA-w5h7-mw56-4v7x- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
tastyigniter/tastyigniterPackagist |
before 4.0.0 | 4.0.0 |
tastyigniter/tastyigniterPackagist |
before 4.0.0, plus listed versions 2.1.02.1.0-rc.12.1.0-rc.22.1.1v0.5.0 Show 45 moreShow lessv1.0.0v1.1.0v1.2.0v1.2.1v1.3.0v1.3.1v1.4.0v1.4.1v3.0.4v3.0.4-betav3.0.4-beta.10v3.0.4-beta.11v3.0.4-beta.12v3.0.4-beta.13v3.0.4-beta.14v3.0.4-beta.15v3.0.4-beta.16v3.0.4-beta.17v3.0.4-beta.18v3.0.4-beta.19v3.0.4-beta.2v3.0.4-beta.20v3.0.4-beta.20.1v3.0.4-beta.21v3.0.4-beta.22v3.0.4-beta.22.1v3.0.4-beta.22.2v3.0.4-beta.22.3v3.0.4-beta.22.4v3.0.4-beta.23v3.0.4-beta.23.1v3.0.4-beta.23.2v3.0.4-beta.24v3.0.4-beta.24.1v3.0.4-beta.24.2v3.0.4-beta.24.3v3.0.4-beta.24.4v3.0.4-beta.25v3.0.4-beta.25.1v3.0.4-beta.25.2v3.0.4-beta.26v3.0.4-beta.27v3.0.4-beta.28v3.0.4-beta.3v3.0.4-beta.4 |
4.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-44314 is a medium vulnerability (CVSS 6.5) in Tastyigniter, published March 18, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in tastyigniter/tastyigniter 4.0.0.
References
github.com/tastyigniter/TastyIgniter/blob/3.x/app/admin/controllers/Orders.php
medium.com/@cnetsec/cve-2024-44314-incorrect-access-control-in-function-updateorder-fc5f2b1b0467
nvd.nist.gov/vuln/detail/CVE-2024-44314
github.com/advisories/GHSA-w5h7-mw56-4v7x
github.com/CVEProject/cvelistV5/tree/main/cves/2024/44xxx/CVE-2024-44314.json
github.com/tastyigniter/TastyIgniter
Left out here: 46 versions. The JSON record has them.