CVE-2024-45054
Potential Permission Leakage of Cluster Level in hwameistor
Hwameistor is an HA local storage system for cloud-native stateful workloads. This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been patched in version 0.14.6. All users are advised to upgrade. Users unable to upgrade should update and limit the ClusterRole using security-role.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
2.8
Potential Permission Leakage of Cluster Level in hwameistor
Hwameistor is an HA local storage system for cloud-native stateful workloads. This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been patched in version 0.14.6. All users are advised to upgrade. Users unable to upgrade should update and limit the ClusterRole using security-role.
- Record
CVE-2024-45054- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
EUVDEUVD-2024-2617
2.8
Hwameistor is an HA local storage system for cloud-native stateful workloads. This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been patched in version 0.14.6. All users are advised to upgrade. Users unable to upgrade should update and limit the ClusterRole using security-role.
- Record
EUVD-2024-2617- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mgwr-h7mv-fh29
4.6
Hwameistor Potential Permission Leakage of Cluster Level
Impact
What kind of vulnerability is it? Who is impacted? This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation.
Patches
Has the problem been patched? What versions should users upgrade to?
= v0.14.6
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading? Update and Limit the ClusterRole using security-role.
References
Are there any links users can visit to find out more? issues: https://github.com/hwameistor/hwameistor/issues/1457 https://github.com/hwameistor/hwameistor/issues/1460
also reported by users via mails: sparkEchooo, younaman
- Record
GHSA-mgwr-h7mv-fh29- CVSS 4.0
- 4.6 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 2.3 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200, CWE-266
- Updated
- 2026-11-02
NVD
2.8
Hwameistor is an HA local storage system for cloud-native stateful workloads. This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been patched in version 0.14.6. All users are advised to upgrade. Users unable to upgrade should update and limit the ClusterRole using security-role.
- Record
CVE-2024-45054- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N - CVSS 3.1
- 6.7 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
2.8
Potential Permission Leakage of Cluster Level in hwameistor
Hwameistor is an HA local storage system for cloud-native stateful workloads. This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation. This issue has been patched in version 0.14.6. All users are advised to upgrade. Users unable to upgrade should update and limit the ClusterRole using security-role.
- Record
CVE-2024-45054- CVSS 3.1
- 2.8 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-mgwr-h7mv-fh29
4.6
Hwameistor Potential Permission Leakage of Cluster Level
Impact
What kind of vulnerability is it? Who is impacted? This ClusterRole has * verbs of * resources. If a malicious user can access the worker node which has hwameistor's deployment, he/she can abuse these excessive permissions to do whatever he/she likes to the whole cluster, resulting in a cluster-level privilege escalation.
Patches
Has the problem been patched? What versions should users upgrade to?
= v0.14.6
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading? Update and Limit the ClusterRole using security-role.
References
Are there any links users can visit to find out more? issues: https://github.com/hwameistor/hwameistor/issues/1457 https://github.com/hwameistor/hwameistor/issues/1460
also reported by users via mails: sparkEchooo, younaman
- Record
GHSA-mgwr-h7mv-fh29- CVSS 4.0
- 4.6 Medium
CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 2.3 Low
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200, CWE-266
- Updated
- 2026-11-02
OSVGO-2024-3103 No score
Hwameistor Potential Permission Leakage of Cluster Level in github.com/hwameistor/hwameistor
Hwameistor Potential Permission Leakage of Cluster Level in github.com/hwameistor/hwameistor
- Record
GO-2024-3103- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/hwameistor/hwameistorGo |
through 0.14.5 | 0.14.6 |
github.com/hwameistor/hwameistorGo |
before 0.14.6 | 0.14.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-45054 is a low vulnerability (CVSS 2.8) in Hwameistor, published August 28, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 16th percentile. Fixed in github.com/hwameistor/hwameistor 0.14.6.
References
github.com/hwameistor/hwameistor/security/advisories/GHSA-mgwr-h7mv-fh29
github.com/hwameistor/hwameistor/issues/1457
github.com/hwameistor/hwameistor/issues/1460
github.com/hwameistor/hwameistor/commit/edf4cebed73cadd230bf97eab65c5311f2858450
github.com/hwameistor/hwameistor/blob/main/helm/hwameistor/templates/clusterrole.yaml
nvd.nist.gov/vuln/detail/CVE-2024-45054
github.com/advisories/GHSA-mgwr-h7mv-fh29
github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45054.json
github.com/hwameistor/hwameistor