Every CVE Search/ Get API key

CVE-2024-45125

Adobe Commerce | Incorrect Authorization (CWE-863)

4.3 MediumFix available

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.53%Up 0.5 points since Oct 11, 2024
90%50%10%1%

What each source reports

CVE List Score used 4.3

Adobe Commerce | Incorrect Authorization (CWE-863)

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
CVE-2024-45125
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2024-3167 4.3

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
EUVD-2024-3167
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-xg36-8c2v-jpxh 5.3

Magento Open Source Incorrect Authorization vulnerability

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
GHSA-xg36-8c2v-jpxh
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
NVD 4.3

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
CVE-2024-45125
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSV 4.3

Adobe Commerce | Incorrect Authorization (CWE-863)

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
CVE-2024-45125
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVGHSA-xg36-8c2v-jpxh 5.3

Magento Open Source Incorrect Authorization vulnerability

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
GHSA-xg36-8c2v-jpxh
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
4.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-863
Updated
2026-11-02
OSVBIT-magento-2024-45125 No score

Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could exploit this vulnerability to have a low impact on integrity. Exploitation of this issue does not require user interaction.

Record
BIT-magento-2024-45125
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
magento/community-edition
Packagist
2.4.7-beta1 up to 2.4.7-p3
2.4.7-p3
magento/community-edition
Packagist
2.4.6-p1 up to 2.4.6-p8
2.4.6-p8
magento/community-edition
Packagist
2.4.5-p1 up to 2.4.5-p10
2.4.5-p10
magento/community-edition
Packagist
before 2.4.4-p11
2.4.4-p11
magento/community-edition
Packagist
2.4.7 to 2.4.7 None known
magento/community-edition
Packagist
2.4.6 to 2.4.6 None known
magento/community-edition
Packagist
2.4.5 to 2.4.5 None known
magento/community-edition
Packagist
2.4.4 to 2.4.4 None known
magento
Bitnami
2.4.7-alpha0 up to 2.4.7-p3, 2.4.6-alpha0 up to 2.4.6-p8, 2.4.5-alpha0 up to 2.4.5-p10, before 2.4.4-p11
2.4.7-p32.4.6-p82.4.5-p102.4.4-p11
magento/community-edition
Packagist
2.4.7-beta1 up to 2.4.7-p3, plus listed versions
2.4.72.4.7-beta22.4.7-beta32.4.7-p12.4.7-p2
2.4.7-p3
Show 7 moreShow less
Affected packages
PackageAffectedFixed
magento/community-edition
Packagist
2.4.6-p1 up to 2.4.6-p8, plus listed versions
2.4.6-p22.4.6-p32.4.6-p42.4.6-p52.4.6-p62.4.6-p7
2.4.6-p8
magento/community-edition
Packagist
2.4.5-p1 up to 2.4.5-p10, plus listed versions
2.4.5-p22.4.5-p32.4.5-p42.4.5-p52.4.5-p62.4.5-p72.4.5-p82.4.5-p9
2.4.5-p10
magento/community-edition
Packagist
before 2.4.4-p11, plus listed versions
0.1.0-alpha1000.1.0-alpha1010.1.0-alpha1020.1.0-alpha1030.1.0-alpha104
Show 45 moreShow less
0.1.0-alpha1050.1.0-alpha1060.1.0-alpha1070.1.0-alpha1080.1.0-alpha890.1.0-alpha900.1.0-alpha910.1.0-alpha920.1.0-alpha930.1.0-alpha940.1.0-alpha950.1.0-alpha960.1.0-alpha970.1.0-alpha980.1.0-alpha990.42.0-beta10.42.0-beta100.42.0-beta110.42.0-beta20.42.0-beta30.42.0-beta40.42.0-beta50.42.0-beta60.42.0-beta70.42.0-beta80.42.0-beta90.74.0-beta10.74.0-beta100.74.0-beta110.74.0-beta120.74.0-beta130.74.0-beta140.74.0-beta150.74.0-beta160.74.0-beta20.74.0-beta30.74.0-beta40.74.0-beta50.74.0-beta60.74.0-beta70.74.0-beta80.74.0-beta91.0.0-beta1.0.0-beta21.0.0-beta3
2.4.4-p11
magento/community-edition
Packagist
Listed versions
2.4.7
None known
magento/community-edition
Packagist
Listed versions
2.4.6
None known
magento/community-edition
Packagist
Listed versions
2.4.5
None known
magento/community-edition
Packagist
Listed versions
2.4.4
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-45125 is a medium vulnerability (CVSS 4.3) in Adobe Commerce, published October 10, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. Fixed in magento/community-edition 2.4.7-p3.

References

This page doesn't list everything

Left out here: 98 versions. The JSON record has them.

MoveEnter Open