CVE-2024-45237
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a ...
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
CVE-2024-45237- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
CVE-2024-45237- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2024-41378
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
EUVD-2024-41378- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-wpp2-87q7-h53v
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a ...
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
GHSA-wpp2-87q7-h53v- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
CVE-2024-45237- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-45237
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
DEBIAN-CVE-2024-45237- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-45237
9.8
An issue was discovered in Fort before 1.6.3. A malicious RPKI repository that descends from a (trusted) Trust Anchor can serve (via rsync or RRDP) a resource certificate containing a Key Usage extension composed of more than two bytes of data. Fort writes this string into a 2-byte buffer without properly sanitizing its length, leading to a buffer overflow.
- Record
UBUNTU-CVE-2024-45237- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-7813-1 No score
fort-validator vulnerabilities
Niklas Vogel and Haya Schulmann discovered that FORT Validator did not perform proper input validation when parsing certain RPKI repository data. A remote attacker could possibly use this issue to cause FORT Validator to crash, resulting in a denial of service. (CVE-2024-45234, CVE-2024-45235, CVE-2024-45236, CVE-2024-45238, CVE-2024-45239)
Niklas Vogel and Haya Schulmann discovered that FORT Validator did not perform proper input validation when parsing resource certificates. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2024-45237)
Koen van Hove discovered that FORT Validator did not limit the duration of data transfers when fetching RPKI repository data. A remote attacker could possibly use this issue to cause FORT Validator to consume excessive resources, resulting in a denial of service. (CVE-2024-48943)
- Record
USN-7813-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fort-validatorDebian:12 |
before 1.5.4-1+deb12u1, plus listed versions 1.5.4-1 |
1.5.4-1+deb12u1 |
fort-validatorDebian:13 |
before 1.6.3-1 | 1.6.3-1 |
fort-validatorDebian:14 |
before 1.6.3-1 | 1.6.3-1 |
fort-validatorDebian:11 From an advisory covering 7 CVEs |
before 1.5.3-1~deb11u2, plus listed versions 1.5.0-11.5.1-11.5.2-11.5.3-1~deb11u1 |
1.5.3-1~deb11u2 |
fort-validatorUbuntu:Pro:20.04:LTS |
before 1.2.0-1ubuntu0.1~esm1, plus listed versions 1.1.1-21.1.2-11.1.3-11.2.0-1 |
1.2.0-1ubuntu0.1~esm1 |
fort-validatorUbuntu:22.04:LTS |
before 1.5.3-1ubuntu0.1, plus listed versions 1.5.1-11.5.2-11.5.3-11.5.3-1build1 |
1.5.3-1ubuntu0.1 |
fort-validatorUbuntu:Pro:24.04:LTS |
before 1.6.1-1ubuntu0.1~esm2, plus listed versions 1.5.4-11.6.1-11.6.1-1build21.6.1-1build3 |
1.6.1-1ubuntu0.1~esm2 |
fort-validatorUbuntu:Pro:20.04:LTS From an advisory covering 7 CVEs |
before 1.2.0-1ubuntu0.1~esm1, plus listed versions 1.1.1-21.1.2-11.1.3-11.2.0-1 |
1.2.0-1ubuntu0.1~esm1 |
fort-validatorUbuntu:22.04:LTS From an advisory covering 7 CVEs |
before 1.5.3-1ubuntu0.1, plus listed versions 1.5.1-11.5.2-11.5.3-11.5.3-1build1 |
1.5.3-1ubuntu0.1 |
fort-validatorUbuntu:Pro:24.04:LTS From an advisory covering 7 CVEs |
before 1.6.1-1ubuntu0.1~esm2, plus listed versions 1.5.4-11.6.1-11.6.1-1build21.6.1-1build3 |
1.6.1-1ubuntu0.1~esm2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-45237 is a critical vulnerability (CVSS 9.8) in Fort Validator Project Validator, published August 24, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in fort-validator 1.5.4-1+deb12u1.