Every CVE Search/ Get API key

CVE-2024-45624

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a...

7.5 HighFix available

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.53%Up 0.5 points since Sep 12, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
CVE-2024-45624
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
EUVDEUVD-2024-41545 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
EUVD-2024-41545
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-x87c-6pgx-5c37 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a...

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
GHSA-x87c-6pgx-5c37
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
NVD 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
CVE-2024-45624
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVALPINE-CVE-2024-45624 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
ALPINE-CVE-2024-45624
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2024-45624 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
DEBIAN-CVE-2024-45624
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2024-45624 7.5

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
UBUNTU-CVE-2024-45624
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSV No score

Exposure of sensitive information due to incompatible policies issue exists in Pgpool-II. If a database user accesses a query cache, table data unauthorized for the user may be retrieved.

Record
CVE-2024-45624
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgpool
Alpine:v3.21
before 4.5.4-r0
4.5.4-r0
pgpool
Alpine:v3.22
before 4.5.4-r0
4.5.4-r0
pgpool
Alpine:v3.23
before 4.5.4-r0
4.5.4-r0
pgpool
Alpine:v3.24
before 4.5.4-r0
4.5.4-r0
pgpool2
Debian:12
before 4.3.5-1+deb12u1, plus listed versions
4.3.5-1
4.3.5-1+deb12u1
pgpool2
Debian:13
before 4.5.4-1
4.5.4-1
pgpool2
Debian:14
before 4.5.4-1
4.5.4-1
pgpool2
Debian:11
From an advisory covering 2 CVEs
before 4.1.4-3+deb11u1, plus listed versions
4.1.4-3
4.1.4-3+deb11u1
pgpool2
Debian:12
From an advisory covering 2 CVEs
before 4.3.5-1+deb12u1, plus listed versions
4.3.5-1
4.3.5-1+deb12u1
pgpool2
Ubuntu:16.04:LTS
All versions, plus listed versions
3.3.4-13.4.3-1
None known
Show 4 moreShow less
Affected packages
PackageAffectedFixed
pgpool2
Ubuntu:20.04:LTS
All versions, plus listed versions
4.0.2-14.0.6-14.0.6-24.1.0-14.1.1-1
None known
pgpool2
Ubuntu:22.04:LTS
All versions, plus listed versions
4.1.4-34.1.4-54.1.4-6build1
None known
pgpool2
Ubuntu:24.04:LTS
All versions, plus listed versions
4.3.5-14.3.5-34.3.7-14.3.7-1ubuntu34.3.7-1ubuntu4
None known
pgpool2
Ubuntu:25.10
All versions, plus listed versions
4.6.0-14.6.0-24.6.1-24.6.3-2
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-45624 is a high vulnerability (CVSS 7.5) in Pgpool Pgpool-ii, published September 12, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 44th percentile. Fixed in pgpool 4.5.4-r0.

References

MoveEnter Open