Every CVE Search/ Get API key

CVE-2024-45690

Moodle: idor when deleting oauth2 linked accounts

7.5 HighFix available

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.36%Up 0.3 points since Nov 21, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.5

Moodle: idor when deleting oauth2 linked accounts

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
CVE-2024-45690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-276
Updated
2026-11-02
EUVDEUVD-2024-3354 7.5

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
EUVD-2024-3354
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-fhg2-r2h9-h7q8 5.3

Moodle IDOR when deleting OAuth2 linked accounts

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
GHSA-fhg2-r2h9-h7q8
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-276, CWE-639
Updated
2026-11-02
NVD 7.5

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
CVE-2024-45690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-276
Updated
2026-11-02
OSV 7.5

Moodle: idor when deleting oauth2 linked accounts

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
CVE-2024-45690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-fhg2-r2h9-h7q8 5.3

Moodle IDOR when deleting OAuth2 linked accounts

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
GHSA-fhg2-r2h9-h7q8
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-276, CWE-639
Updated
2026-11-02
OSVUBUNTU-CVE-2024-45690 7.5

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
UBUNTU-CVE-2024-45690
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVBIT-moodle-2024-45690 No score

Moodle: idor when deleting oauth2 linked accounts

A flaw was found in Moodle. Additional checks were required to ensure users can only delete their OAuth2-linked accounts.

Record
BIT-moodle-2024-45690
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 4.1.13
4.1.13
moodle/moodle
Packagist
4.2.0-beta up to 4.2.10
4.2.10
moodle/moodle
Packagist
4.3.0-beta up to 4.3.7
4.3.7
moodle/moodle
Packagist
4.4.0-beta up to 4.4.3
4.4.3
moodle
Bitnami
before 4.1.13, 4.2.0 up to 4.2.10, 4.3.0 up to 4.3.7, 4.4.0 up to 4.4.3
4.1.134.2.104.3.74.4.3
moodle/moodle
Packagist
before 4.1.13, plus listed versions
v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6
Show 45 moreShow less
v2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1
4.1.13
moodle/moodle
Packagist
4.2.0-beta up to 4.2.10, plus listed versions
v4.2.0v4.2.0-betav4.2.0-rc1v4.2.0-rc2v4.2.1
Show 8 moreShow less
v4.2.2v4.2.3v4.2.4v4.2.5v4.2.6v4.2.7v4.2.8v4.2.9
4.2.10
moodle/moodle
Packagist
4.3.0-beta up to 4.3.7, plus listed versions
v4.3.0v4.3.0-betav4.3.0-rc1v4.3.0-rc2v4.3.1
Show 5 moreShow less
v4.3.2v4.3.3v4.3.4v4.3.5v4.3.6
4.3.7
moodle/moodle
Packagist
4.4.0-beta up to 4.4.3, plus listed versions
v4.4.0v4.4.0-betav4.4.0-rc1v4.4.0-rc2v4.4.1v4.4.2
4.4.3
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-45690 is a high vulnerability (CVSS 7.5) in Moodle, published November 20, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 30th percentile. Fixed in moodle/moodle 4.1.13.

References

Show 4 moreShow less
This page doesn't list everything

Left out here: 295 versions. The JSON record has them.

MoveEnter Open