CVE-2024-46304
A Buffer Overflow vulnerability in libcoap v4.3.5-rc2 and below allows a remote attacker to cause...
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
CVE-2024-46304- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2024-41812
7.5
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
EUVD-2024-41812- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-335x-3rg7-689m
7.5
A Buffer Overflow vulnerability in libcoap v4.3.5-rc2 and below allows a remote attacker to cause...
A Buffer Overflow vulnerability in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
GHSA-335x-3rg7-689m- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
NVD
7.5
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
CVE-2024-46304- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSV
7.5
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
CVE-2024-46304- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-46304
7.5
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
DEBIAN-CVE-2024-46304- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-46304
7.5
A NULL pointer dereference in libcoap v4.3.5-rc2 and below allows a remote attacker to cause a denial of service via the coap_handle_request_put_block function in src/coap_block.c.
- Record
UBUNTU-CVE-2024-46304- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libcoap3Debian:12 |
All versions, plus listed versions 4.3.1-14.3.1-24.3.3-14.3.4-14.3.4-1.1 Show 5 moreShow less4.3.4-1.1~exp14.3.5-14.3.5-24.3.5-34.3.5-4 |
None known |
libcoap3Debian:13 |
All versions, plus listed versions 4.3.4-1.14.3.4-1.1+deb13u14.3.4-1.1+deb13u24.3.4-1.1+deb13u34.3.5-14.3.5-24.3.5-34.3.5-4 |
None known |
libcoap3Debian:14 |
before 4.3.5-1, plus listed versions 4.3.4-1.1 |
4.3.5-1 |
libcoapUbuntu:18.04:LTS |
All versions, plus listed versions 4.1.2-1 |
None known |
libcoap2Ubuntu:20.04:LTS |
All versions, plus listed versions 4.2.0-24.2.1-1 |
None known |
libcoap2Ubuntu:22.04:LTS |
All versions, plus listed versions 4.2.1-14.2.1-1build1 |
None known |
libcoap3Ubuntu:22.04:LTS |
All versions, plus listed versions 4.3.0-24.3.0-2build1 |
None known |
libcoap3Ubuntu:24.04:LTS |
All versions, plus listed versions 4.3.1-24.3.3-14.3.4-14.3.4-1.1build24.3.4-1.1build34.3.4-1.1build4 |
None known |
libcoap3Ubuntu:25.10 |
All versions, plus listed versions 4.3.4-1.1build4 |
None known |
libcoap3Ubuntu:26.10 |
All versions, plus listed versions 4.3.5-24.3.5-34.3.5-44.3.5-4ubuntu1 |
None known |
libcoap3Ubuntu:26.04:LTS |
All versions, plus listed versions 4.3.4-1.1build44.3.5-14.3.5-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-46304 is a high vulnerability (CVSS 7.5) in Libcoap, published October 9, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.56%, the 46th percentile. Fixed in libcoap3 4.3.5-1.
References
github.com/obgm/libcoap/issues/1509
nvd.nist.gov/vuln/detail/CVE-2024-46304
github.com/advisories/GHSA-335x-3rg7-689m
github.com/CVEProject/cvelistV5/tree/main/cves/2024/46xxx/CVE-2024-46304.json
security-tracker.debian.org/tracker/CVE-2024-46304
ubuntu.com/security/CVE-2024-46304
cve.org/CVERecord?id=CVE-2024-46304