CVE-2024-47090
XSS via WYSIWYG editor
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Passive
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.1
XSS via WYSIWYG editor
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
CVE-2024-47090- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2024-54988
5.1
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
EUVD-2024-54988- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x3pm-6vfp-j66v
5.1
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
GHSA-x3pm-6vfp-j66v- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.1
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
CVE-2024-47090- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.1
XSS via WYSIWYG editor
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
CVE-2024-47090- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-47090
6.1
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
DEBIAN-CVE-2024-47090- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-47090
5.1
Improper neutralization of input in Nagvis before version 1.9.47 which can lead to XSS
- Record
UBUNTU-CVE-2024-47090- CVSS 4.0
- 5.1 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
nagvisDebian:12 |
All versions, plus listed versions 1:1.10.0-11:1.10.1-11:1.10.2-11:1.10.3-11:1.10.4-1 Show 21 moreShow less1:1.10.5-11:1.10.6-11:1.10.7-11:1.9.34-11:1.9.35-11:1.9.35-1~exp11:1.9.36-11:1.9.37-11:1.9.38-11:1.9.39-11:1.9.40-11:1.9.41-11:1.9.42-11:1.9.43-11:1.9.44-11:1.9.45-11:1.9.46-11:1.9.47-11:1.9.47-1~exp11:1.9.48-11:1.9.49-1 |
None known |
nagvisDebian:13 |
before 1:1.9.47-1 | 1:1.9.47-1 |
nagvisDebian:14 |
before 1:1.9.47-1 | 1:1.9.47-1 |
nagvisDebian:11 From an advisory covering 2 CVEs |
before 1:1.9.25-2+deb11u2, plus listed versions 1:1.9.25-21:1.9.25-2+deb11u1 |
1:1.9.25-2+deb11u2 |
nagvisUbuntu:16.04:LTS |
All versions, plus listed versions 1:1.7.10+dfsg1-31:1.7.10+dfsg1-3ubuntu1 |
None known |
nagvisUbuntu:18.04:LTS |
All versions, plus listed versions 1:1.7.10+dfsg1-3.2 |
None known |
nagvisUbuntu:22.04:LTS |
All versions, plus listed versions 1:1.9.25-21:1.9.27-11:1.9.28-11:1.9.29-11:1.9.30-1 |
None known |
nagvisUbuntu:24.04:LTS |
All versions, plus listed versions 1:1.9.36-11:1.9.38-11:1.9.39-11:1.9.40-1 |
None known |
nagvisUbuntu:25.10 |
All versions, plus listed versions 1:1.9.44-11:1.9.46-11:1.9.47-1 |
None known |
nagvisUbuntu:26.10 |
All versions, plus listed versions 1:1.9.48-11:1.10.3-11:1.10.4-11:1.10.5-11:1.10.6-1 |
None known |
nagvisUbuntu:26.04:LTS |
All versions, plus listed versions 1:1.9.47-11:1.9.48-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-47090 is a medium vulnerability (CVSS 5.1) in Nagvis, published May 27, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 13th percentile. Fixed in nagvis 1:1.9.47-1.
References
nagvis.org/downloads/changelog/1.9.47
lists.debian.org/debian-lts-announce/2025/06/msg00031.html
nvd.nist.gov/vuln/detail/CVE-2024-47090
github.com/advisories/GHSA-x3pm-6vfp-j66v
github.com/CVEProject/cvelistV5/tree/main/cves/2024/47xxx/CVE-2024-47090.json
security-tracker.debian.org/tracker/CVE-2024-47090
ubuntu.com/security/CVE-2024-47090
cve.org/CVERecord?id=CVE-2024-47090
github.com/NagVis/nagvis/commit/5baf87d30175357aaa39e42ff0d99fb0abefbc06