CVE-2024-47516
Pagure: argument injection in pagurerepo.log()
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
Pagure: argument injection in pagurerepo.log()
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
CVE-2024-47516- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88
- Updated
- 2026-11-02
EUVDEUVD-2024-54309
9.8
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
EUVD-2024-54309- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-cfhx-3wmq-q5rg
9.8
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the...
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
GHSA-cfhx-3wmq-q5rg- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88
- Updated
- 2026-11-02
NVD
9.8
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
CVE-2024-47516- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-88
- Updated
- 2026-11-02
OSV
9.8
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
CVE-2024-47516- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-47516
9.8
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
DEBIAN-CVE-2024-47516- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-47516
9.8
A vulnerability was found in Pagure. An argument injection in Git during retrieval of the repository history leads to remote code execution on the Pagure instance.
- Record
UBUNTU-CVE-2024-47516- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-7984-1 No score
pagure vulnerabilities
Thomas Chauchefoin discovered that Pagure incorrectly handled symbolic links in Git repositories. A remote attacker could possibly use this issue to cause Pagure to expose files outside the intended repository boundaries. (CVE-2024-4981)
Thomas Chauchefoin discovered that Pagure did not properly sanitize path inputs. A remote attacker could possibly use this issue to read arbitrary files. (CVE-2024-4982)
Thomas Chauchefoin discovered that Pagure incorrectly handled symbolic links during repository archiving. A remote attacker could possibly use this issue to disclose local files on the server. (CVE-2024-47515)
Thomas Chauchefoin discovered that Pagure incorrectly handled certain inputs. A remote attacker could possibly use this issue to execute arbitrary code on the server. (CVE-2024-47516)
- Record
USN-7984-1- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pagureDebian:13 |
before 5.14.1+dfsg-1 | 5.14.1+dfsg-1 |
pagureDebian:11 From an advisory covering 4 CVEs |
before 5.11.3+dfsg-1+deb11u1, plus listed versions 5.11.3+dfsg-1 |
5.11.3+dfsg-1+deb11u1 |
pagureUbuntu:22.04:LTS |
before 5.11.3+dfsg-1ubuntu0.1, plus listed versions 5.11.3+dfsg-1 |
5.11.3+dfsg-1ubuntu0.1 |
pagureUbuntu:24.04:LTS |
before 5.11.3+dfsg-2.1ubuntu0.2, plus listed versions 5.11.3+dfsg-2.15.11.3+dfsg-2.1ubuntu0.1 |
5.11.3+dfsg-2.1ubuntu0.2 |
pagureUbuntu:Pro:20.04:LTS From an advisory covering 4 CVEs |
before 5.8.1+dfsg-3ubuntu0.1~esm1, plus listed versions 5.8.1+dfsg-15.8.1+dfsg-3 |
5.8.1+dfsg-3ubuntu0.1~esm1 |
pagureUbuntu:22.04:LTS From an advisory covering 4 CVEs |
before 5.11.3+dfsg-1ubuntu0.1, plus listed versions 5.11.3+dfsg-1 |
5.11.3+dfsg-1ubuntu0.1 |
pagureUbuntu:24.04:LTS From an advisory covering 4 CVEs |
before 5.11.3+dfsg-2.1ubuntu0.2, plus listed versions 5.11.3+dfsg-2.15.11.3+dfsg-2.1ubuntu0.1 |
5.11.3+dfsg-2.1ubuntu0.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-47516 is a critical vulnerability (CVSS 9.8) in pagure, published March 25, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in pagure 5.14.1+dfsg-1.