CVE-2024-48057
LocalAI Cross-site Scripting vulnerability
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.1
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- Record
CVE-2024-48057- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-352
- Updated
- 2026-11-02
EUVDEUVD-2024-3254
6.1
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- Record
EUVD-2024-3254- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ghx4-cgxw-7h9p
2.1
LocalAI Cross-site Scripting vulnerability
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- Record
GHSA-ghx4-cgxw-7h9p- CVSS 4.0
- 2.1 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-352
- Updated
- 2026-11-02
NVD
6.1
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- Record
CVE-2024-48057- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-352
- Updated
- 2026-11-02
OSV
6.1
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- Record
CVE-2024-48057- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-ghx4-cgxw-7h9p
2.1
LocalAI Cross-site Scripting vulnerability
localai <=2.20.1 is vulnerable to Cross Site Scripting (XSS). When calling the delete model API and passing inappropriate parameters, it can cause a one-time storage XSS, which will trigger the payload when a user accesses the homepage.
- Record
GHSA-ghx4-cgxw-7h9p- CVSS 4.0
- 2.1 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-352, CWE-79
- Updated
- 2026-11-02
OSVGO-2024-3253 No score
LocalAI Cross-site Scripting vulnerability in github.com/mudler/LocalAI
LocalAI Cross-site Scripting vulnerability in github.com/mudler/LocalAI
- Record
GO-2024-3253- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:14470-1 No score
govulncheck-vulndb-0.0.20241106T172143-1.1 on GA media
These are all security issues fixed in the govulncheck-vulndb-0.0.20241106T172143-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:14470-1- Updated
- 2026-11-02
OSVSUSE-SU-2024:4042-1 No score
Security update for govulncheck-vulndb
This update for govulncheck-vulndb fixes the following issues:
-
Update to version 0.0.20241112T145010 2024-11-12T14:50:10Z. Refs jsc#PED-11136 Go CVE Numbering Authority IDs added or updated with aliases:
- GO-2024-3250 CVE-2024-51744 GHSA-29wx-vh33-7x7r
-
Update to version 0.0.20241108T172500 2024-11-08T17:25:00Z. Refs jsc#PED-11136 Go CVE Numbering Authority IDs added or updated with aliases:
- GO-2024-3260 CVE-2024-45794 GHSA-q78v-cv36-8fxj
- GO-2024-3262 CVE-2024-10975 GHSA-2w5v-x29g-jw7j
-
Update to version 0.0.20241106T172143 2024-11-06T17:21:43Z. Refs jsc#PED-11136 Go CVE Numbering Authority IDs added or updated with aliases:
- GO-2024-3251 CVE-2024-10389 GHSA-q3rp-vvm7-j8jg
- GO-2024-3252 CVE-2024-51746 GHSA-8pmp-678w-c8xx
- GO-2024-3253 CVE-2024-48057 GHSA-ghx4-cgxw-7h9p
- GO-2024-3254 CVE-2024-51735 GHSA-wvv7-wm5v-w2gv
- Record
SUSE-SU-2024:4042-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/mudler/LocalAIGo |
through 2.20.1 | None known |
github.com/mudler/LocalAIGo |
All versions | None known |
govulncheck-vulndbSUSE:Linux Enterprise Module for Package Hub 15 SP5 From an advisory covering 7 CVEs |
before 0.0.20241112T145010-150000.1.17.1 | 0.0.20241112T145010-150000.1.17.1 |
govulncheck-vulndbSUSE:Linux Enterprise Module for Package Hub 15 SP6 From an advisory covering 7 CVEs |
before 0.0.20241112T145010-150000.1.17.1 | 0.0.20241112T145010-150000.1.17.1 |
govulncheck-vulndbopenSUSE:Leap 15.5 From an advisory covering 7 CVEs |
before 0.0.20241112T145010-150000.1.17.1 | 0.0.20241112T145010-150000.1.17.1 |
govulncheck-vulndbopenSUSE:Leap 15.6 From an advisory covering 7 CVEs |
before 0.0.20241112T145010-150000.1.17.1 | 0.0.20241112T145010-150000.1.17.1 |
govulncheck-vulndbopenSUSE:Tumbleweed From an advisory covering 4 CVEs |
before 0.0.20241106T172143-1.1 | 0.0.20241106T172143-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-48057 is a medium vulnerability (CVSS 6.1) in Mudler Localai, published November 4, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.24%, the 14th percentile. No source names a fixed version.
References
rumbling-slice-eb0.notion.site/LocalAI-deleted-model-with-storage-XSS-CSRF-vulnerability-in-mudler-localai-101e3cda9e8c80e0ac12fe418d5dd982?pvs=4
gist.github.com/AfterSnows/1bd7ee5a3a42dbb5f5ff67f7f9c8ccec
nvd.nist.gov/vuln/detail/CVE-2024-48057
github.com/mudler/LocalAI/blob/master/core/http/views/index.html
github.com/advisories/GHSA-ghx4-cgxw-7h9p
github.com/mudler/localai/commit/a1634b219a4e52813e70ff07e6376a01449c4515
Show 11 moreShow less
github.com/CVEProject/cvelistV5/tree/main/cves/2024/48xxx/CVE-2024-48057.json
github.com/mudler/LocalAI
suse.com/support/update/announcement/2024/suse-su-20244042-1
suse.com/security/cve/CVE-2024-10389
suse.com/security/cve/CVE-2024-10975
suse.com/security/cve/CVE-2024-45794
suse.com/security/cve/CVE-2024-48057
suse.com/security/cve/CVE-2024-51735
suse.com/security/cve/CVE-2024-51744
suse.com/security/cve/CVE-2024-51746
lists.opensuse.org/archives/list/[email protected]/thread/OX53GMPD3MLNI5INQF5WZ3M4WW7BFHZC