CVE-2024-48897
Moodle: idor in edit/delete rss feed
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
CVE-2024-48897- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
CVE List
6.5
Moodle: idor in edit/delete rss feed
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
CVE-2024-48897- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2024-3325
6.5
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
EUVD-2024-3325- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-x3x9-349x-2485
6.9
moodle: IDOR in edit/delete RSS feed
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
GHSA-x3x9-349x-2485- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
OSV
6.5
Moodle: idor in edit/delete rss feed
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
CVE-2024-48897- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-x3x9-349x-2485
6.9
moodle: IDOR in edit/delete RSS feed
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
GHSA-x3x9-349x-2485- CVSS 4.0
- 6.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-48897
6.5
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
UBUNTU-CVE-2024-48897- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVBIT-moodle-2024-48897 No score
Moodle: idor in edit/delete rss feed
A vulnerability was found in Moodle. Additional checks are required to ensure users can only edit or delete RSS feeds that they have permission to modify.
- Record
BIT-moodle-2024-48897- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 4.1.14 | 4.1.14 |
moodle/moodlePackagist |
4.2.0 up to 4.2.11 | 4.2.11 |
moodle/moodlePackagist |
4.3.0 up to 4.3.8 | 4.3.8 |
moodle/moodlePackagist |
4.4.0 up to 4.4.4 | 4.4.4 |
moodleBitnami |
before 4.1.19, 4.2.0 up to 4.4.9 | 4.1.194.4.9 |
moodle/moodlePackagist |
before 4.1.14, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
4.1.14 |
moodle/moodlePackagist |
4.2.0 up to 4.2.11, plus listed versions v4.2.0v4.2.1v4.2.10v4.2.2v4.2.3 Show 6 moreShow lessv4.2.4v4.2.5v4.2.6v4.2.7v4.2.8v4.2.9 |
4.2.11 |
moodle/moodlePackagist |
4.3.0 up to 4.3.8, plus listed versions v4.3.0v4.3.1v4.3.2v4.3.3v4.3.4v4.3.5v4.3.6v4.3.7 |
4.3.8 |
moodle/moodlePackagist |
4.4.0 up to 4.4.4, plus listed versions v4.4.0v4.4.1v4.4.2v4.4.3 |
4.4.4 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-48897 is a medium vulnerability (CVSS 4.3) in Moodle, published November 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in moodle/moodle 4.1.14.
References
bugzilla.redhat.com/show_bug.cgi?id=2318821
nvd.nist.gov/vuln/detail/CVE-2024-48897
github.com/advisories/GHSA-x3x9-349x-2485
moodle.org
github.com/CVEProject/cvelistV5/tree/main/cves/2024/48xxx/CVE-2024-48897.json
github.com/moodle/moodle
ubuntu.com/security/CVE-2024-48897
cve.org/CVERecord?id=CVE-2024-48897
Left out here: 296 versions. The JSON record has them.