CVE-2024-48943
fort-validator - security update
A malicious RPKI rsync repository can prevent Fort from finishing its validation run by drip-feeding its content.
What each source reports
OSVUBUNTU-CVE-2024-48943 No score
A malicious RPKI rsync repository can prevent Fort from finishing its validation run by drip-feeding its content.
- Record
UBUNTU-CVE-2024-48943- Updated
- 2026-11-02
OSVUSN-7813-1 No score
fort-validator vulnerabilities
Niklas Vogel and Haya Schulmann discovered that FORT Validator did not perform proper input validation when parsing certain RPKI repository data. A remote attacker could possibly use this issue to cause FORT Validator to crash, resulting in a denial of service. (CVE-2024-45234, CVE-2024-45235, CVE-2024-45236, CVE-2024-45238, CVE-2024-45239)
Niklas Vogel and Haya Schulmann discovered that FORT Validator did not perform proper input validation when parsing resource certificates. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2024-45237)
Koen van Hove discovered that FORT Validator did not limit the duration of data transfers when fetching RPKI repository data. A remote attacker could possibly use this issue to cause FORT Validator to consume excessive resources, resulting in a denial of service. (CVE-2024-48943)
- Record
USN-7813-1- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
fort-validatorDebian:12 |
before 1.5.4-1+deb12u1, plus listed versions 1.5.4-1 |
1.5.4-1+deb12u1 |
fort-validatorDebian:13 |
before 1.6.4-1 | 1.6.4-1 |
fort-validatorDebian:14 |
before 1.6.4-1 | 1.6.4-1 |
fort-validatorDebian:11 From an advisory covering 7 CVEs |
before 1.5.3-1~deb11u2, plus listed versions 1.5.0-11.5.1-11.5.2-11.5.3-1~deb11u1 |
1.5.3-1~deb11u2 |
fort-validatorUbuntu:Pro:20.04:LTS |
before 1.2.0-1ubuntu0.1~esm1, plus listed versions 1.1.1-21.1.2-11.1.3-11.2.0-1 |
1.2.0-1ubuntu0.1~esm1 |
fort-validatorUbuntu:22.04:LTS |
before 1.5.3-1ubuntu0.1, plus listed versions 1.5.1-11.5.2-11.5.3-11.5.3-1build1 |
1.5.3-1ubuntu0.1 |
fort-validatorUbuntu:Pro:24.04:LTS |
before 1.6.1-1ubuntu0.1~esm2, plus listed versions 1.5.4-11.6.1-11.6.1-1build21.6.1-1build3 |
1.6.1-1ubuntu0.1~esm2 |
fort-validatorUbuntu:Pro:20.04:LTS From an advisory covering 7 CVEs |
before 1.2.0-1ubuntu0.1~esm1, plus listed versions 1.1.1-21.1.2-11.1.3-11.2.0-1 |
1.2.0-1ubuntu0.1~esm1 |
fort-validatorUbuntu:22.04:LTS From an advisory covering 7 CVEs |
before 1.5.3-1ubuntu0.1, plus listed versions 1.5.1-11.5.2-11.5.3-11.5.3-1build1 |
1.5.3-1ubuntu0.1 |
fort-validatorUbuntu:Pro:24.04:LTS From an advisory covering 7 CVEs |
before 1.6.1-1ubuntu0.1~esm2, plus listed versions 1.5.4-11.6.1-11.6.1-1build21.6.1-1build3 |
1.6.1-1ubuntu0.1~esm2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-48943 is a vulnerability with no CVSS score yet in fort-validator, published January 1, 0001. No source lists public exploit code. Fixed in fort-validator 1.5.4-1+deb12u1.