CVE-2024-50610
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many...
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
CVE-2024-50610- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Weakness
- CWE-190
- Updated
- 2026-11-02
EUVDEUVD-2024-44974
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
EUVD-2024-44974- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pj8w-xcg3-82vx
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many...
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
GHSA-pj8w-xcg3-82vx- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Weakness
- CWE-190
- Updated
- 2026-11-02
NVD
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
CVE-2024-50610- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Weakness
- CWE-190
- Updated
- 2026-11-02
OSV
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
CVE-2024-50610- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-50610
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
DEBIAN-CVE-2024-50610- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Updated
- 2026-11-02
Show 5 moreShow less
OSVOESA-2024-2361
3.6
gsl security update
The GNU Scientific Library (GSL) is a collection of routines for numerical analysis, written in C.
Security Fix(es):
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.(CVE-2024-50610)
- Record
OESA-2024-2361- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-50610
3.6
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
UBUNTU-CVE-2024-50610- CVSS 3.1
- 3.6 Low
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L - Updated
- 2026-11-02
OSVAZL-51868 No score
CVE-2024-50610 affecting package gsl 2.6-3
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
AZL-51868- Updated
- 2026-11-02
OSVAZL-51881 No score
CVE-2024-50610 affecting package gsl 2.8-1
GSL (GNU Scientific Library) through 2.8 has an integer signedness error in gsl_siman_solve_many in siman/siman.c. When params.n_tries is negative, incorrect memory allocation occurs.
- Record
AZL-51881- Updated
- 2026-11-05
OSVopenSUSE-SU-2026:10449-1 No score
gsl-2.8-5.1 on GA media
These are all security issues fixed in the gsl-2.8-5.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2026:10449-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gslAzure Linux:2 |
through 2.6-3 | None known |
gslAzure Linux:3 |
through 2.8-1 | None known |
gslDebian:12 |
All versions, plus listed versions 2.7.1+dfsg-52.7.1+dfsg-5+deb12u12.7.1+dfsg-62.8+dfsg-12.8+dfsg-2 Show 5 moreShow less2.8+dfsg-32.8+dfsg-42.8+dfsg-52.8+dfsg-5.12.8+dfsg-6 |
None known |
gslDebian:13 |
before 2.8+dfsg-4 | 2.8+dfsg-4 |
gslDebian:14 |
before 2.8+dfsg-4 | 2.8+dfsg-4 |
gslopenEuler:22.03-LTS-SP1 |
before 2.4-10.oe2203sp1 | 2.4-10.oe2203sp1 |
gslopenEuler:24.03-LTS |
before 2.7-3.oe2403 | 2.7-3.oe2403 |
gslopenEuler:22.03-LTS-SP4 |
before 2.4-12.oe2203sp4 | 2.4-12.oe2203sp4 |
gslopenEuler:22.03-LTS-SP3 |
before 2.4-11.oe2203sp3 | 2.4-11.oe2203sp3 |
gslopenEuler:20.03-LTS-SP4 |
before 2.4-10.oe2003sp4 | 2.4-10.oe2003sp4 |
Show 9 moreShow less
| Package | Affected | Fixed |
|---|---|---|
gslUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.16+dfsg-42.0+dfsg-1ubuntu12.1+dfsg-22.1+dfsg-2ubuntu0.1~esm1 |
None known |
gslUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 2.4+dfsg-62.4+dfsg-6ubuntu0.1~esm1 |
None known |
gslUbuntu:20.04:LTS |
All versions, plus listed versions 2.5+dfsg-62.5+dfsg-6build12.5+dfsg-6+deb10u1build0.20.04.1 |
None known |
gslUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 2.6+dfsg-22.7.1+dfsg-32.7.1+dfsg-3ubuntu0.22.04.1~esm1 |
None known |
gslUbuntu:24.04:LTS |
All versions, plus listed versions 2.7.1+dfsg-6ubuntu12.7.1+dfsg-6ubuntu2 |
None known |
gslUbuntu:25.10 |
All versions, plus listed versions 2.8+dfsg-5ubuntu12.8+dfsg-5ubuntu22.8+dfsg-5.1ubuntu1 |
None known |
gslUbuntu:26.10 |
All versions, plus listed versions 2.8+dfsg-62.8+dfsg-6ubuntu1 |
None known |
gslUbuntu:26.04:LTS |
All versions, plus listed versions 2.8+dfsg-5.1ubuntu12.8+dfsg-6 |
None known |
gslopenSUSE:Tumbleweed |
before 2.8-5.1 | 2.8-5.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-50610 is a low vulnerability (CVSS 3.6) in Gnu Scientific Library, published October 27, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in gsl 2.8+dfsg-4.