CVE-2024-52553
Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.8
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login.
- Record
CVE-2024-52553- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
EUVDEUVD-2024-3259
8.8
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login.
- Record
EUVD-2024-3259- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h23j-73ww-7594
8.8
Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login. This allows attackers to use social engineering techniques to gain administrator access to Jenkins. OpenId Connect Authentication Plugin 4.421.v5422614eb_e0a_ invalidates the existing session on login.
- Record
GHSA-h23j-73ww-7594- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-384, CWE-613
- Updated
- 2026-11-02
NVD
8.8
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login.
- Record
CVE-2024-52553- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
OSV
8.8
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login.
- Record
CVE-2024-52553- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-h23j-73ww-7594
8.8
Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login. This allows attackers to use social engineering techniques to gain administrator access to Jenkins. OpenId Connect Authentication Plugin 4.421.v5422614eb_e0a_ invalidates the existing session on login.
- Record
GHSA-h23j-73ww-7594- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-384, CWE-613
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:oic-authMaven |
before 4.421.v5422614eb | 4.421.v5422614eb |
org.jenkins-ci.plugins:oic-authMaven |
before 4.421.v5422614eb, plus listed versions 1.01.11.21.31.4 Show 45 moreShow less1.51.61.71.82.0.02.12.22.32.42.52.63.04.220.v22331f08e6a_34.223.v503b_9a_75a_8a_f4.224.v62720cfa_026e4.225.v03326773b_44b_4.227.v36610663f7604.228.v0c3e8682ff1f4.229.vf736b_fec02f44.236.v4124503b_a_f884.238.v0021f710b_b_f44.239.v325750a_96f3b_4.250.v5a_d9932264374.257.v5360e8489e8b_4.269.va_7526f34f3064.279.vca_c1e2fdd24b_4.284.v0cc21de03d374.290.v6f5e8da_e98b_24.297.vcddb_d8a_e46944.299.v5ca_eb_6a_f3e6d4.303.v84089a_708ea_74.320.v23537cb_a_b_5c64.324.vfd49d010926b_4.329.v994d3f265d684.330.v6fdfc07513e34.331.vd925b_f76f3a_c4.340.ve70636c6590e4.346.v10401f5436224.350.v347c3b_8b_9d954.354.v321ce67a_1de84.355.v3a_fb_fca_b_96d44.371.vc7c0c06e8a_f54.388.v4f73328eb_d2c4.409.ve864b_f48b_0f34.411.v990b_9d36e74e |
4.421.v5422614eb |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-52553 is a high vulnerability (CVSS 8.8) in Jenkins Openid, published November 13, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.66%, the 51st percentile. Fixed in org.jenkins-ci.plugins:oic-auth 4.421.v5422614eb.
References
Left out here: 1 version. The JSON record has them.