CVE-2024-52796
Password Pusher's rate limiter can be bypassed by forging proxy headers
Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
5.3
Password Pusher's rate limiter can be bypassed by forging proxy headers
Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
- Record
CVE-2024-52796- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-770
- Updated
- 2026-11-02
EUVDEUVD-2024-3353
5.3
Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
- Record
EUVD-2024-3353- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-ffp2-8p2h-4m5j
2.7
Password Pusher rate limiter can be bypassed by forging proxy headers
Impact
Password Pusher comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service.
Additionally, with the ability to bypass rate limiting, it also allows attackers to more easily execute brute force attacks.
Patches
In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue.
If you are running a remote proxy, please see this documentation on how to authorize the IP address of your remote proxy.
Workarounds
It is highly suggested to upgrade to at least v1.49.0 to mitigate this risk.
If for some reason you cannot immediately upgrade, the alternative is that you can add rules to your proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
References
The new settings are configurable to authorize remote proxies.
Credits
Thank you to Positive Technologies for reporting and working with me to bring this CVE to the community with the associated fix.
- Record
GHSA-ffp2-8p2h-4m5j- CVSS 4.0
- 2.7 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-770
- Updated
- 2026-11-02
NVD
5.3
Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
- Record
CVE-2024-52796- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-770
- Updated
- 2026-11-02
OSV
5.3
Password Pusher's rate limiter can be bypassed by forging proxy headers
Password Pusher, an open source application to communicate sensitive information over the web, comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service. In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue. As a workaround, one may add rules to one's proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
- Record
CVE-2024-52796- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-770
- Updated
- 2026-11-02
OSVGHSA-ffp2-8p2h-4m5j
2.7
Password Pusher rate limiter can be bypassed by forging proxy headers
Impact
Password Pusher comes with a configurable rate limiter. In versions prior to v1.49.0, the rate limiter could be bypassed by forging proxy headers allowing bad actors to send unlimited traffic to the site potentially causing a denial of service.
Additionally, with the ability to bypass rate limiting, it also allows attackers to more easily execute brute force attacks.
Patches
In v1.49.0, a fix was implemented to only authorize proxies on local IPs which resolves this issue.
If you are running a remote proxy, please see this documentation on how to authorize the IP address of your remote proxy.
Workarounds
It is highly suggested to upgrade to at least v1.49.0 to mitigate this risk.
If for some reason you cannot immediately upgrade, the alternative is that you can add rules to your proxy and/or firewall to not accept external proxy headers such as X-Forwarded-* from clients.
References
The new settings are configurable to authorize remote proxies.
Credits
Thank you to Positive Technologies for reporting and working with me to bring this CVE to the community with the associated fix.
- Record
GHSA-ffp2-8p2h-4m5j- CVSS 4.0
- 2.7 Low
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U - CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L - Weakness
- CWE-770
- Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-52796 is a medium vulnerability (CVSS 5.3) in Pglombardo Password Pusher, published November 20, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in pwpush 1.49.0.
References
github.com/pglombardo/PasswordPusher/security/advisories/GHSA-ffp2-8p2h-4m5j
docs.pwpush.com/docs/proxies
github.com/pglombardo/PasswordPusher/releases/tag/v1.49.0
nvd.nist.gov/vuln/detail/CVE-2024-52796
github.com/rubysec/ruby-advisory-db/blob/master/gems/pwpush/CVE-2024-52796.yml
github.com/advisories/GHSA-ffp2-8p2h-4m5j
github.com/CVEProject/cvelistV5/tree/main/cves/2024/52xxx/CVE-2024-52796.json
github.com/pglombardo/PasswordPusher