CVE-2024-52867
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are...
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
CVE-2024-52867- CVSS 3.1
- 8.1 High
CVSS:3.1/AC:H/AV:L/A:H/C:H/I:H/PR:N/S:C/UI:N - Weakness
- CWE-276
- Updated
- 2026-11-02
EUVDEUVD-2024-45958
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
EUVD-2024-45958- CVSS 3.1
- 8.1 High
CVSS:3.1/AC:H/AV:L/A:H/C:H/I:H/PR:N/S:C/UI:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9h8f-hjmp-pwxx
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are...
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
GHSA-9h8f-hjmp-pwxx- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-276
- Updated
- 2026-11-02
NVD
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
CVE-2024-52867- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-276
- Updated
- 2026-11-02
OSV
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
CVE-2024-52867- CVSS 3.1
- 8.1 High
CVSS:3.1/AC:H/AV:L/A:H/C:H/I:H/PR:N/S:C/UI:N - Updated
- 2026-11-07
OSVDEBIAN-CVE-2024-52867
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
DEBIAN-CVE-2024-52867- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-52867
8.1
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
- Record
UBUNTU-CVE-2024-52867- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-8773-1 No score
guix vulnerability
It was discovered that GNU Guix incorrectly made build outputs accessible to local users before their file metadata was finalized. A local attacker could possibly use this issue to gain elevated privileges.
- Record
USN-8773-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
guixDebian:11 |
before 1.2.0-4+deb11u3, plus listed versions 1.2.0-41.2.0-4+deb11u11.2.0-4+deb11u2 |
1.2.0-4+deb11u3 |
guixDebian:12 |
before 1.4.0-3+deb12u2, plus listed versions 1.4.0-31.4.0-3+deb12u1 |
1.4.0-3+deb12u2 |
guixUbuntu:Pro:22.04:LTS |
before 1.3.0-4ubuntu0.1~esm1, plus listed versions 1.2.0-41.3.0-21.3.0-4 |
1.3.0-4ubuntu0.1~esm1 |
guixUbuntu:Pro:24.04:LTS |
before 1.4.0-6ubuntu0.1~esm1, plus listed versions 1.4.0-51.4.0-61.4.0-6build1 |
1.4.0-6ubuntu0.1~esm1 |
guixUbuntu:Pro:22.04:LTS From an advisory covering 2 CVEs |
before 1.3.0-4ubuntu0.1~esm1, plus listed versions 1.2.0-41.3.0-21.3.0-4 |
1.3.0-4ubuntu0.1~esm1 |
guixUbuntu:Pro:24.04:LTS From an advisory covering 2 CVEs |
before 1.4.0-6ubuntu0.1~esm1, plus listed versions 1.4.0-51.4.0-61.4.0-6build1 |
1.4.0-6ubuntu0.1~esm1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | OSV | |
| facts | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-52867 is a high vulnerability (CVSS 8.1) in Gnu Guix, published November 8, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.23%, the 13th percentile. Fixed in guix 1.2.0-4+deb11u3.
References
guix.gnu.org/en/blog/2024/build-user-takeover-vulnerability
git.savannah.gnu.org/cgit/guix.git/commit?id=558224140dab669cabdaebabff18504a066c48d4
git.savannah.gnu.org/cgit/guix.git/commit?id=5ab3c4c1e43ebb637551223791db0ea3519986e1
lists.debian.org/debian-lts-announce/2024/11/msg00016.html
nvd.nist.gov/vuln/detail/CVE-2024-52867
github.com/advisories/GHSA-9h8f-hjmp-pwxx