CVE-2024-52947
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers...
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
6.1
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
CVE-2024-52947- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2024-45981
6.1
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
EUVD-2024-45981- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-425w-xhjg-hfcm
5.4
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers...
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
GHSA-425w-xhjg-hfcm- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
5.4
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
CVE-2024-52947- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
CVE-2024-52947- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-52947
5.4
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
DEBIAN-CVE-2024-52947- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-52947
5.4
A cross-site scripting (XSS) vulnerability in LemonLDAP::NG before 2.20.1 allows remote attackers to inject arbitrary web script or HTML via the url parameter of the upgrade session confirmation page (upgradeSession / forceUpgrade) if the "Upgrade session" plugin has been enabled by an admin
- Record
UBUNTU-CVE-2024-52947- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lemonldap-ngDebian:12 |
before 2.16.1+ds-deb12u4, plus listed versions 2.16.1+ds-22.16.1+ds-deb12u12.16.1+ds-deb12u22.16.1+ds-deb12u3 |
2.16.1+ds-deb12u4 |
lemonldap-ngDebian:13 |
before 2.20.1+ds-1 | 2.20.1+ds-1 |
lemonldap-ngDebian:14 |
before 2.20.1+ds-1 | 2.20.1+ds-1 |
lemonldap-ngDebian:11 From an advisory covering 3 CVEs |
before 2.0.11+ds-4+deb11u6, plus listed versions 2.0.11+ds-42.0.11+ds-4+deb11u12.0.11+ds-4+deb11u22.0.11+ds-4+deb11u42.0.11+ds-4+deb11u5 |
2.0.11+ds-4+deb11u6 |
lemonldap-ngUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.3-11.4.6-11.4.6-21.4.6-3 |
None known |
lemonldap-ngUbuntu:18.04:LTS |
All versions, plus listed versions 1.9.10-11.9.13-21.9.14-11.9.15-11.9.16-2 |
None known |
lemonldap-ngUbuntu:20.04:LTS |
All versions, plus listed versions 2.0.5+ds-22.0.6+ds-22.0.7+ds-2 |
None known |
lemonldap-ngUbuntu:22.04:LTS |
All versions, plus listed versions 2.0.11+ds-42.0.13+ds-32.0.13+ds-3ubuntu1 |
None known |
lemonldap-ngUbuntu:24.04:LTS |
All versions, plus listed versions 2.16.2+ds-12.17.1+ds-12.17.2+ds-12.17.2+ds-22.18.1+ds-12.18.2+ds-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-52947 is a medium vulnerability (CVSS 6.1) in lemonldap-ng, published November 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.33%, the 26th percentile. Fixed in lemonldap-ng 2.16.1+ds-deb12u4.
References
gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/3257
lists.debian.org/debian-lts-announce/2024/11/msg00037.html
nvd.nist.gov/vuln/detail/CVE-2024-52947
github.com/advisories/GHSA-425w-xhjg-hfcm
github.com/CVEProject/cvelistV5/tree/main/cves/2024/52xxx/CVE-2024-52947.json
security-tracker.debian.org/tracker/CVE-2024-52947
ubuntu.com/security/CVE-2024-52947
cve.org/CVERecord?id=CVE-2024-52947