CVE-2024-53382
PrismJS DOM Clobbering vulnerability
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.9
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
CVE-2024-53382- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2024-53973
4.9
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
EUVD-2024-53973- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-x7hr-w5r2-h6wg
4.9
PrismJS DOM Clobbering vulnerability
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
GHSA-x7hr-w5r2-h6wg- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-94
- Updated
- 2026-11-02
NVD
4.9
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
CVE-2024-53382- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-94, CWE-79
- Updated
- 2026-11-02
OSV
4.9
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
CVE-2024-53382- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-94
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-53382
5.4
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
DEBIAN-CVE-2024-53382- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Show 6 moreShow less
OSVGHSA-x7hr-w5r2-h6wg
4.9
PrismJS DOM Clobbering vulnerability
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
GHSA-x7hr-w5r2-h6wg- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-94
- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2024-53382
4.9
CVE-2024-53382 in @rootio/prismjs - Patched by Root
Root has patched CVE-2024-53382 in the @rootio/prismjs package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2024-53382- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-53382
4.9
Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.
- Record
UBUNTU-CVE-2024-53382- CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N - CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1778719550 No score
TuxCare security update for prismjs (1 CVE)
TuxCare rebuilt prismjs to address 1 CVE. Fixed in 1.29.0-tuxcare.1.
- Record
CLSA-2026-1778719550- Updated
- 2026-11-02
OSVCLSA-2026-1778719553 No score
TuxCare security update for prismjs (1 CVE)
TuxCare rebuilt prismjs to address 1 CVE. Fixed in 1.27.0-tuxcare.1.
- Record
CLSA-2026-1778719553- Updated
- 2026-11-02
OSVCLSA-2026-1793304056 No score
TuxCare security update for prismjs (6 CVEs)
TuxCare rebuilt prismjs to address 6 CVEs. Fixed in 1.17.1-tuxcare.1.
- Record
CLSA-2026-1793304056- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
prismjsnpm |
before 1.30.0 | 1.30.0 |
prismjsTuxCare:npm |
1.29.0-tuxcare.0 up to 1.29.0-tuxcare.1, plus listed versions 1.29.0 |
1.29.0-tuxcare.1 |
prismjsTuxCare:npm |
1.27.0-tuxcare.0 up to 1.27.0-tuxcare.1, plus listed versions 1.27.0 |
1.27.0-tuxcare.1 |
prismjsTuxCare:npm From an advisory covering 6 CVEs |
1.17.1-tuxcare.0 up to 1.17.1-tuxcare.1, plus listed versions 1.17.1 |
1.17.1-tuxcare.1 |
node-prismjsDebian:12 |
All versions, plus listed versions 1.29.0+dfsg+~1.26.0-11.30.0+dfsg+~1.26.5-11.30.0+dfsg+~1.26.5-21.30.0+dfsg+~1.26.6-1 |
None known |
node-prismjsDebian:13 |
All versions, plus listed versions 1.29.0+dfsg+~1.26.0-11.30.0+dfsg+~1.26.5-11.30.0+dfsg+~1.26.5-21.30.0+dfsg+~1.26.6-1 |
None known |
node-prismjsDebian:14 |
before 1.30.0+dfsg+~1.26.5-1, plus listed versions 1.29.0+dfsg+~1.26.0-1 |
1.30.0+dfsg+~1.26.5-1 |
@rootio/prismjsRoot:npm |
before 1.27.0-root.io.2 | 1.27.0-root.io.21.27.0-root.io.1 |
prismjsRoot:npm |
before 1.27.0-aikido.2 | 1.27.0-aikido.2 |
node-prismjsUbuntu:20.04:LTS |
All versions, plus listed versions 1.11.0+dfsg-21.11.0+dfsg-3 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
node-prismjsUbuntu:22.04:LTS |
All versions, plus listed versions 1.23.0+dfsg-11.25.0+dfsg-11.27.0+dfsg+~1.26.0-1 |
None known |
node-prismjsUbuntu:24.04:LTS |
All versions, plus listed versions 1.29.0+dfsg+~1.26.0-1 |
None known |
node-prismjsUbuntu:25.10 |
All versions, plus listed versions 1.29.0+dfsg+~1.26.0-11.30.0+dfsg+~1.26.5-1 |
None known |
node-prismjsUbuntu:26.10 |
All versions, plus listed versions 1.30.0+dfsg+~1.26.6-1 |
None known |
node-prismjsUbuntu:26.04:LTS |
All versions, plus listed versions 1.30.0+dfsg+~1.26.5-11.30.0+dfsg+~1.26.5-21.30.0+dfsg+~1.26.6-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-53382 is a medium vulnerability (CVSS 4.9) in Prismjs Prism, published March 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 27th percentile. Fixed in prismjs 1.30.0.
References
gist.github.com/jackfromeast/aeb128e44f05f95828a1a824708df660
github.com/PrismJS/prism/blob/59e5a3471377057de1f401ba38337aca27b80e03/prism.js
nvd.nist.gov/vuln/detail/CVE-2024-53382
github.com/PrismJS/prism/pull/3863
github.com/PrismJS/prism/commit/8e8b9352dac64457194dd9e51096b4772532e53d
github.com/advisories/GHSA-x7hr-w5r2-h6wg