CVE-2024-53432
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std:...
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
CVE-2024-53432- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-754
- Updated
- 2026-11-02
EUVDEUVD-2024-51966
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
EUVD-2024-51966- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6q3r-569c-crm7
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std:...
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
GHSA-6q3r-569c-crm7- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-754
- Updated
- 2026-11-02
NVD
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
CVE-2024-53432- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-754
- Updated
- 2026-11-02
OSV
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
CVE-2024-53432- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-53432
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
DEBIAN-CVE-2024-53432- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-53432
7.5
While parsing certain malformed PLY files, PCL version 1.14.1 crashes due to an uncaught std::out_of_range exception in PCLPointCloud2::at. This issue could potentially be exploited to cause a denial-of-service (DoS) attack when processing untrusted PLY files.
- Record
UBUNTU-CVE-2024-53432- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-7227-1 No score
PCL vulnerability
It was discovered that PCL incorrectly handled certain malformed files. If a user or automated system were tricked into opening a specially crafted file, an attacker could possibly exploit this to cause a denial of service.
- Record
USN-7227-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pclDebian:12 |
All versions, plus listed versions 1.13.0+dfsg-31.13.0+dfsg-41.14.0+dfsg-11.14.0+dfsg-21.14.0+dfsg-3 Show 10 moreShow less1.14.0+dfsg-41.14.0+dfsg-51.15.0+dfsg-11.15.0+dfsg-21.15.0+dfsg-31.15.0+dfsg-41.15.1+dfsg-11.15.1+dfsg-21.15.1+dfsg-31.15.1+dfsg-4 |
None known |
pclDebian:13 |
before 1.15.0+dfsg-2 | 1.15.0+dfsg-2 |
pclDebian:14 |
before 1.15.0+dfsg-2 | 1.15.0+dfsg-2 |
pclUbuntu:Pro:16.04:LTS |
before 1.7.2-14ubuntu0.1+esm1, plus listed versions 1.7.2-10build11.7.2-131.7.2-14build11.7.2-14build1.11.7.2-14ubuntu0.1 |
1.7.2-14ubuntu0.1+esm1 |
pclUbuntu:Pro:18.04:LTS |
before 1.8.1+dfsg1-2ubuntu2.18.04.1+esm1, plus listed versions 1.8.1+dfsg1-2ubuntu11.8.1+dfsg1-2ubuntu21.8.1+dfsg1-2ubuntu2.18.04.1 |
1.8.1+dfsg1-2ubuntu2.18.04.1+esm1 |
pclUbuntu:Pro:20.04:LTS |
before 1.10.0+dfsg-5ubuntu1+esm2, plus listed versions 1.9.1+dfsg1-10ubuntu21.9.1+dfsg1-10ubuntu31.10.0+dfsg-4ubuntu21.10.0+dfsg-5ubuntu11.10.0+dfsg-5ubuntu1+esm1 |
1.10.0+dfsg-5ubuntu1+esm2 |
pclUbuntu:Pro:22.04:LTS |
before 1.12.1+dfsg-3ubuntu0.1~esm2, plus listed versions 1.11.1+dfsg-1build11.12.0+dfsg-5build11.12.0+dfsg-61.12.1+dfsg-31.12.1+dfsg-3build11.12.1+dfsg-3ubuntu0.1~esm1 |
1.12.1+dfsg-3ubuntu0.1~esm2 |
pclUbuntu:Pro:24.04:LTS |
before 1.14.0+dfsg-1ubuntu0.1~esm1, plus listed versions 1.13.0+dfsg-31.13.0+dfsg-3build11.13.0+dfsg-41.13.0+dfsg-4build21.13.0+dfsg-4build31.14.0+dfsg-1 |
1.14.0+dfsg-1ubuntu0.1~esm1 |
pclUbuntu:25.10 |
All versions, plus listed versions 1.14.0+dfsg-5ubuntu11.15.0+dfsg-21.15.0+dfsg-2build2 |
None known |
pclUbuntu:26.10 |
All versions, plus listed versions 1.15.1+dfsg-21.15.1+dfsg-31.15.1+dfsg-3build1 |
None known |
pclUbuntu:26.04:LTS |
All versions, plus listed versions 1.15.0+dfsg-2build21.15.0+dfsg-31.15.1+dfsg-11.15.1+dfsg-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-53432 is a high vulnerability (CVSS 7.5) in Point Cloud Library Pcl, published November 21, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.71%, the 53rd percentile. Fixed in pcl 1.15.0+dfsg-2.