CVE-2024-53589
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's...
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.4
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
CVE-2024-53589- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2024-52003
8.4
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
EUVD-2024-52003- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-6hcg-vqw2-35jw
8.4
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's...
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
GHSA-6hcg-vqw2-35jw- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
NVD
8.4
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
CVE-2024-53589- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVBELL-CVE-2024-53589
8.4
- Record
BELL-CVE-2024-53589- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-53589
8.4
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
DEBIAN-CVE-2024-53589- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVROOT-OS-DEBIAN-12-CVE-2024-53589
6.6
CVE-2024-53589 in binutils - Patched by Root
Root has patched CVE-2024-53589 in the binutils package for Root:Debian:12. Multiple fixed versions available.
- Record
ROOT-OS-DEBIAN-12-CVE-2024-53589- CVSS 3.1
- 6.6 Medium
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-53589
8.4
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
UBUNTU-CVE-2024-53589- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
GNU objdump 2.43 is vulnerable to Buffer Overflow in the BFD (Binary File Descriptor) library's handling of tekhex format files.
- Record
CVE-2024-53589- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
binutilsAlpaquita:23 |
2.39-r2 up to 2.40-r5 | 2.40-r5 |
binutilsAlpaquita:stream |
2.40-r4 up to 2.44-r0 | 2.44-r0 |
binutilsBellSoft Hardened Containers:23 |
2.39-r2 up to 2.40-r5 | 2.40-r5 |
binutilsBellSoft Hardened Containers:stream |
2.40-r4 up to 2.44-r0 | 2.44-r0 |
binutilsDebian:12 |
All versions, plus listed versions 2.40-22.40.50.20230111-12.40.50.20230215-12.40.50.20230501-12.40.50.20230510-1 Show 45 moreShow less2.40.50.20230602-12.40.50.20230611-12.40.50.20230611-22.40.50.20230622-12.40.50.20230625-12.40.50.20230630-12.40.90.20230705-12.40.90.20230714-12.40.90.20230714-22.40.90.20230720-12.40.90.20230729-12.40.90.20230729-22.41-12.41-22.41-32.41-42.41-52.41-62.41-72.41.50.20230731-12.41.50.20230803-12.41.50.20230905-12.41.50.20231010-12.41.50.20231101-12.41.50.20231125-12.41.50.20231202-12.41.50.20231206-12.41.50.20231214-12.41.50.20231227-12.41.90.20240115-12.41.90.20240122-12.42-12.42-22.42-2+hurd.12.42-32.42-42.42.50.20240614-12.42.50.20240618-12.42.50.20240625-12.42.50.20240710-12.42.90.20240720-12.42.90.20240720-22.43-12.43-22.43.1-1 |
None known |
binutilsDebian:13 |
before 2.44-1 | 2.44-1 |
binutilsDebian:14 |
before 2.44-1 | 2.44-1 |
binutilsRoot:Debian:12 |
before 2.40-2.root.io.17 | 2.40-2.root.io.172.40-2.root.io.182.40-2.root.io.192.40-2.root.io.202.40-2.root.io.212.40-2.root.io.222.40-2.root.io.232.40-2.root.io.242.40-2.aikido.25 |
rootio-binutilsRoot:Debian:12 |
before 2.40-2.root.io.17 | 2.40-2.root.io.172.40-2.root.io.182.40-2.root.io.192.40-2.root.io.202.40-2.root.io.212.40-2.root.io.222.40-2.root.io.232.40-2.root.io.242.40-2.aikido.25 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-53589 is a high vulnerability (CVSS 8.4) in binutils, published December 5, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 18th percentile. Fixed in binutils 2.40-r5.
References
gnu.org/software/binutils
bushido-sec.com/index.php/2024/12/05/binutils-objdump-tekhex-buffer-overflow
security.netapp.com/advisory/ntap-20250314-0006
nvd.nist.gov/vuln/detail/CVE-2024-53589
github.com/advisories/GHSA-6hcg-vqw2-35jw
docs.bell-sw.com/security/cves/CVE-2024-53589
security-tracker.debian.org/tracker/CVE-2024-53589
ubuntu.com/security/CVE-2024-53589
cve.org/CVERecord?id=CVE-2024-53589
Left out here: 79 versions. The JSON record has them.