CVE-2024-53856
rPGP Panics on Malformed Untrusted Input
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
rPGP Panics on Malformed Untrusted Input
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
- Record
CVE-2024-53856- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-130, CWE-148, CWE-617
- Updated
- 2026-11-02
EUVDEUVD-2024-3456
7.5
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
- Record
EUVD-2024-3456- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9rmp-2568-59rv
8.7
rPGP Panics on Malformed Untrusted Input
During a security audit, Radically Open Security discovered several reachable edge cases which allow an attacker to trigger rpgp crashes by providing crafted data.
Impact
When processing malformed input, rpgp can run into Rust panics which halt the program.
This can happen in the following scenarios:
- Parsing OpenPGP messages from binary or armor format
- Decrypting OpenPGP messages via
decrypt_with_password() - Parsing or converting public keys
- Parsing signed cleartext messages from armor format
- Using malformed private keys to sign or encrypt
Given the affected components, we consider most attack vectors to be reachable by remote attackers during typical use cases of the rpgp library. The attack complexity is low since the malformed messages are generic, short, and require no victim-specific knowledge.
The result is a denial-of-service impact via program termination. There is no impact to confidentiality or integrity security properties.
Versions and Patches
All recent versions are affected by at least some of the above mentioned issues.
The vulnerabilities have been fixed with version 0.14.1. We recommend all users to upgrade to this version.
References
The security audit was made possible by the NLnet Foundation NGI Zero Core grant program for rpgp.
- Record
GHSA-9rmp-2568-59rv- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-130, CWE-248, CWE-617
- Updated
- 2026-11-02
NVD
7.5
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
- Record
CVE-2024-53856- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-130, CWE-148, CWE-617
- Updated
- 2026-11-02
OSV
7.5
rPGP Panics on Malformed Untrusted Input
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
- Record
CVE-2024-53856- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-130, CWE-148, CWE-617
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-53856
7.5
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
- Record
DEBIAN-CVE-2024-53856- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-9rmp-2568-59rv
8.7
rPGP Panics on Malformed Untrusted Input
During a security audit, Radically Open Security discovered several reachable edge cases which allow an attacker to trigger rpgp crashes by providing crafted data.
Impact
When processing malformed input, rpgp can run into Rust panics which halt the program.
This can happen in the following scenarios:
- Parsing OpenPGP messages from binary or armor format
- Decrypting OpenPGP messages via
decrypt_with_password() - Parsing or converting public keys
- Parsing signed cleartext messages from armor format
- Using malformed private keys to sign or encrypt
Given the affected components, we consider most attack vectors to be reachable by remote attackers during typical use cases of the rpgp library. The attack complexity is low since the malformed messages are generic, short, and require no victim-specific knowledge.
The result is a denial-of-service impact via program termination. There is no impact to confidentiality or integrity security properties.
Versions and Patches
All recent versions are affected by at least some of the above mentioned issues.
The vulnerabilities have been fixed with version 0.14.1. We recommend all users to upgrade to this version.
References
The security audit was made possible by the NLnet Foundation NGI Zero Core grant program for rpgp.
- Record
GHSA-9rmp-2568-59rv- CVSS 4.0
- 8.7 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-130, CWE-248, CWE-617
- Updated
- 2026-11-02
OSVRUSTSEC-2024-0447
7.5
Panics on Malformed Untrusted Input
During a security audit, Radically Open Security discovered several reachable edge cases which allow an attacker to trigger rpgp crashes by providing crafted data.
Impact
When processing malformed input, rpgp can run into Rust panics which halt the program.
This can happen in the following scenarios:
- Parsing OpenPGP messages from binary or armor format
- Decrypting OpenPGP messages via decrypt_with_password()
- Parsing or converting public keys
- Parsing signed cleartext messages from armor format
- Using malformed private keys to sign or encrypt
Given the affected components, we consider most attack vectors to be reachable by remote attackers during typical use cases of the rpgp library. The attack complexity is low since the malformed messages are generic, short, and require no victim-specific knowledge.
The result is a denial-of-service impact via program termination. There is no impact to confidentiality or integrity security properties.
Versions and Patches
All recent versions are affected by at least some of the above mentioned issues.
The vulnerabilities have been fixed with version 0.14.1. We recommend all users to upgrade to this version.
References
The security audit was made possible by the NLnet Foundation NGI Zero Core grant program for rpgp.
- Record
RUSTSEC-2024-0447- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-53856 is a high vulnerability (CVSS 7.5) in Rpgp, published December 5, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in pgp 0.14.1.
References
github.com/rpgp/rpgp/security/advisories/GHSA-9rmp-2568-59rv
nvd.nist.gov/vuln/detail/CVE-2024-53856
rustsec.org/advisories/RUSTSEC-2024-0447.html
github.com/advisories/GHSA-9rmp-2568-59rv
github.com/CVEProject/cvelistV5/tree/main/cves/2024/53xxx/CVE-2024-53856.json
security-tracker.debian.org/tracker/CVE-2024-53856