Every CVE Search/ Get API key

CVE-2024-53900

Mongoose search injection vulnerability

9.1 CriticalPublic exploitFix available

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

3.98%Up 3.9 points since Dec 3, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.1

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Record
CVE-2024-53900
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-89
Updated
2026-11-02
EUVDEUVD-2024-3487 9.1

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Record
EUVD-2024-3487
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-m7xq-9374-9rvx 8.7

Mongoose search injection vulnerability

Mongoose versions prior to 8.8.3, 7.8.3, 6.13.5, and 5.13.23 are vulnerable to improper use of the $where operator. This vulnerability arises from the ability of the $where clause to execute arbitrary JavaScript code in MongoDB queries, potentially leading to code injection attacks and unauthorized access or manipulation of database data.

Record
GHSA-m7xq-9374-9rvx
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
NVD 9.1

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Record
CVE-2024-53900
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-89
Updated
2026-11-02
OSV 9.1

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Record
CVE-2024-53900
CVSS 3.1
9.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-m7xq-9374-9rvx 8.7

Mongoose search injection vulnerability

Mongoose versions prior to 8.8.3, 7.8.3, 6.13.5, and 5.13.23 are vulnerable to improper use of the $where operator. This vulnerability arises from the ability of the $where clause to execute arbitrary JavaScript code in MongoDB queries, potentially leading to code injection attacks and unauthorized access or manipulation of database data.

Record
GHSA-m7xq-9374-9rvx
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
Show 4 moreShow less
OSVBIT-mongoose-2024-53900 No score

Mongoose before 8.8.3 can improperly use $where in match, leading to search injection.

Record
BIT-mongoose-2024-53900
Updated
2026-11-02
OSVCLSA-2026-1774916718 No score

TuxCare security update for mongoose (1 CVE)

TuxCare rebuilt mongoose to address 1 CVE. Fixed in 6.12.2-tuxcare.1.

Record
CLSA-2026-1774916718
Updated
2026-11-02
OSVCLSA-2026-1786374654 No score

TuxCare security update for mongoose (2 CVEs)

TuxCare rebuilt mongoose to address 2 CVEs. Fixed in 7.8.8-tuxcare.3.

Record
CLSA-2026-1786374654
Updated
2026-11-02
OSVROOT-APP-NPM-CVE-2024-53900 No score

CVE-2024-53900 in mongoose - Patched by Root

Root has patched CVE-2024-53900 in the mongoose package for Root:npm. Multiple fixed versions available.

Record
ROOT-APP-NPM-CVE-2024-53900
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mongoose
npm
8.0.0-rc0 up to 8.8.3
8.8.3
mongoose
npm
7.0.0-rc0 up to 7.8.3
7.8.3
mongoose
npm
6.0.0-rc0 up to 6.13.5
6.13.5
mongoose
npm
3.6.0-rc0 up to 5.13.23
5.13.23
mongoose
Bitnami
before 6.13.5, 7.0.0 up to 8.8.3
6.13.58.8.3
mongoose
TuxCare:npm
6.12.2-tuxcare.0 up to 6.12.2-tuxcare.1, plus listed versions
6.12.2
6.12.2-tuxcare.1
mongoose
TuxCare:npm
7.8.8-tuxcare.0 up to 7.8.8-tuxcare.3, plus listed versions
7.8.87.8.8-tuxcare.17.8.8-tuxcare.2
7.8.8-tuxcare.3
mongoose
Root:npm
before 6.9.1-aikido.4
6.9.1-aikido.45.13.23-aikido.1
@rootio/mongoose
Root:npm
before 6.9.1-root.io.4
6.9.1-root.io.45.13.23-root.io.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiMongoose < 8.8.3 - Remote Code Execution
PoC in GitHubGokul-Krishnan-V-R/CVE-2024-539002025-04-03
PoC in GitHubwww-spam/CVE-2024-539002025-08-19

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-53900 is a critical vulnerability (CVSS 9.1) in Automattic Mongoose, published December 2, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.98%, the 90th percentile. Fixed in mongoose 8.8.3.

References

Show 9 moreShow less
MoveEnter Open