CVE-2024-54682
Zipbomb DoS via Missing Slack Import Validation
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
6.5
Zipbomb DoS via Missing Slack Import Validation
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
- Record
CVE-2024-54682- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-409
- Updated
- 2026-11-02
EUVDEUVD-2024-3533
6.5
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
- Record
EUVD-2024-3533- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v647-h8jj-fw5r
6.5
Mattermost Data Amplification vulnerability
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
- Record
GHSA-v647-h8jj-fw5r- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-409
- Updated
- 2026-11-02
NVD
6.5
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
- Record
CVE-2024-54682- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - CVSS 3.1
- 4.9 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-409
- Updated
- 2026-11-02
OSV
6.5
Zipbomb DoS via Missing Slack Import Validation
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
- Record
CVE-2024-54682- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-409
- Updated
- 2026-11-02
OSVGHSA-v647-h8jj-fw5r
6.5
Mattermost Data Amplification vulnerability
Mattermost versions 10.1.x <= 10.1.2, 10.0.x <= 10.0.2, 9.11.x <= 9.11.4, 9.5.x <= 9.5.12 fail to limit the file size for slack import file uploads which allows a user to cause a DoS via zip bomb by importing data in a team they are a team admin.
- Record
GHSA-v647-h8jj-fw5r- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-409
- Updated
- 2026-11-02
OSVGO-2024-3340 No score
Mattermost Data Amplification vulnerability in github.com/mattermost/mattermost-server
Mattermost Data Amplification vulnerability in github.com/mattermost/mattermost-server
- Record
GO-2024-3340- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:14603-1 No score
govulncheck-vulndb-0.0.20241218T202206-1.1 on GA media
These are all security issues fixed in the govulncheck-vulndb-0.0.20241218T202206-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:14603-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/mattermost/mattermost/server/v8Go |
10.1.0 up to 10.1.3 | 10.1.3 |
github.com/mattermost/mattermost/server/v8Go |
10.0.0 up to 10.0.3 | 10.0.3 |
github.com/mattermost/mattermost/server/v8Go |
9.11.0 up to 9.11.5 | 9.11.5 |
github.com/mattermost/mattermost/server/v8Go |
9.5.0 up to 9.5.13 | 9.5.13 |
github.com/mattermost/mattermost-serverGo |
9.5.0+incompatible up to 9.5.13+incompatible, 9.11.0+incompatible up to 9.11.5+incompatible, 10.0.0+incompatible up to 10.0.3+incompatible, 10.1.0+incompatible up to 10.1.3+incompatible | 9.5.13+incompatible9.11.5+incompatible10.0.3+incompatible10.1.3+incompatible |
github.com/mattermost/mattermost-server/v5Go |
All versions | None known |
github.com/mattermost/mattermost-server/v6Go |
All versions | None known |
github.com/mattermost/mattermost/server/v8Go |
All versions | None known |
govulncheck-vulndbopenSUSE:Tumbleweed From an advisory covering 8 CVEs |
before 0.0.20241218T202206-1.1 | 0.0.20241218T202206-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-54682 is a medium vulnerability (CVSS 6.5) in Mattermost, published December 16, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.44%, the 38th percentile. Fixed in github.com/mattermost/mattermost/server/v8 10.1.3.
References
mattermost.com/security-updates
nvd.nist.gov/vuln/detail/CVE-2024-54682
github.com/advisories/GHSA-v647-h8jj-fw5r
github.com/CVEProject/cvelistV5/tree/main/cves/2024/54xxx/CVE-2024-54682.json
github.com/mattermost/mattermost
lists.opensuse.org/archives/list/[email protected]/thread/GN5BTYONDVDULOG3YURKUJNL2YZ2LDHU