CVE-2024-55564
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.8
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
CVE-2024-55564- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2024-52811
9.8
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
EUVD-2024-52811- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5gjq-58c4-9ff5
9.8
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
GHSA-5gjq-58c4-9ff5- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
NVD
9.8
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
CVE-2024-55564- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2024-55564
9.8
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
DEBIAN-CVE-2024-55564- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2024-55564
9.8
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
UBUNTU-CVE-2024-55564- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
The POSIX::2008 package before 0.24 for Perl has a potential _execve50c env buffer overflow.
- Record
CVE-2024-55564- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libposix-2008-perlDebian:12 |
All versions, plus listed versions 0.16-20.20-10.21-10.23-10.24-1 Show 4 moreShow less0.26-10.27-10.28-10.29-1 |
None known |
libposix-2008-perlDebian:13 |
before 0.24-1 | 0.24-1 |
libposix-2008-perlDebian:14 |
before 0.24-1 | 0.24-1 |
libposix-2008-perlUbuntu:16.04:LTS |
All versions, plus listed versions 0.04-10.04-1build1 |
None known |
libposix-2008-perlUbuntu:18.04:LTS |
All versions, plus listed versions 0.04-1build30.16-1 |
None known |
libposix-2008-perlUbuntu:20.04:LTS |
All versions, plus listed versions 0.16-1build10.16-1build2 |
None known |
libposix-2008-perlUbuntu:22.04:LTS |
All versions, plus listed versions 0.16-1build30.16-1build4 |
None known |
libposix-2008-perlUbuntu:24.04:LTS |
All versions, plus listed versions 0.16-2build10.20-10.21-10.23-10.23-1build10.23-1build2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2024-55564 is a critical vulnerability (CVSS 9.8) in Perl Posix 2028, published December 9, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in libposix-2008-perl 0.24-1.