Every CVE Search/ Get API key

CVE-2024-58249

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are...

3.7 LowFix available

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

0.53%Up 0.5 points since Apr 17, 2025
90%50%10%1%

What each source reports

CVE List Score used 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
CVE-2024-58249
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-826
Updated
2026-11-02
EUVDEUVD-2024-54426 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
EUVD-2024-54426
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-643m-q4f3-rfc2 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are...

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
GHSA-643m-q4f3-rfc2
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-826
Updated
2026-11-02
NVD 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
CVE-2024-58249
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-826
Updated
2026-11-02
OSV 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
CVE-2024-58249
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Weakness
CWE-826
Updated
2026-11-02
OSVDEBIAN-CVE-2024-58249 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
DEBIAN-CVE-2024-58249
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
Show 7 moreShow less
OSVJLSEC-2026-1262 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are...

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
JLSEC-2026-1262
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVOESA-2025-1504 3.7

wxGTK3 security update

wxWidgets is a C++ library for cross-platform GUI. With wxWidgets, you can create applications for different GUIs (GTK+, Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code. This package contains all library of GTK3-backed wxWidgets.

Security Fix(es):

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.(CVE-2024-58249)

Record
OESA-2025-1504
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVOESA-2025-1505 3.7

wxGTK3 security update

wxWidgets is a C++ library for cross-platform GUI. With wxWidgets, you can create applications for different GUIs (GTK+, Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code. This package contains all library of GTK3-backed wxWidgets.

Security Fix(es):

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.(CVE-2024-58249)

Record
OESA-2025-1505
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2024-58249 3.7

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
UBUNTU-CVE-2024-58249
CVSS 3.1
3.7 LowCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVMGASA-2025-0217 No score

Updated wxgtk packages fix security vulnerability

In wxWidgets before 3.2.7, a crash can be triggered in wxWidgets apps when connections are refused in wxWebRequestCURL.

Record
MGASA-2025-0217
Updated
2026-11-02
OSVopenSUSE-SU-2025:15309-1 No score

libwx_gtk2u_adv-suse16_0_0-3.2.8-4.1 on GA media

These are all security issues fixed in the libwx_gtk2u_adv-suse16_0_0-3.2.8-4.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15309-1
Updated
2026-11-02
OSVSUSE-SU-2025:01735-1 No score

Security update for wxWidgets-3_2

This update for wxWidgets-3_2 fixes the following issues:

  • CVE-2024-58249: Fixed crash when connection is refused in wxWebRequestCURL (bsc#1239902)
Record
SUSE-SU-2025:01735-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wxwidgets3.2
Debian:12
All versions, plus listed versions
3.2.11+dfsg-13.2.11+dfsg1-13.2.11+dfsg1-23.2.2+dfsg-23.2.2+dfsg-3
Show 27 moreShow less
3.2.2+dfsg-3~exp13.2.2+dfsg-3~exp23.2.2+dfsg-3~exp33.2.2+dfsg-43.2.3+dfsg-13.2.3+dfsg-1~exp13.2.3+dfsg-1~exp23.2.3+dfsg-1~exp33.2.3+dfsg-23.2.3+dfsg-33.2.4+dfsg-13.2.4+dfsg-23.2.4+dfsg-33.2.4+dfsg-3.13.2.4+dfsg-3.1~exp13.2.4+dfsg-3.1~exp23.2.4+dfsg-43.2.4+dfsg-53.2.5+dfsg-13.2.6+dfsg-13.2.6+dfsg-23.2.6+dfsg-2+ports3.2.7+dfsg-13.2.8+dfsg-13.2.8+dfsg-23.2.8+dfsg-2~exp13.2.9+dfsg-1
None known
wxwidgets3.2
Debian:13
before 3.2.7+dfsg-1
3.2.7+dfsg-1
wxwidgets3.2
Debian:14
before 3.2.7+dfsg-1
3.2.7+dfsg-1
wxWidgets_jll
Julia
All versions None known
wxgtk
Mageia:9
before 3.2.8.1-1.mga9
3.2.8.1-1.mga9
wxGTK3
openEuler:24.03-LTS
before 3.2.2.1-4.oe2403
3.2.2.1-4.oe2403
wxGTK3
openEuler:24.03-LTS-SP1
before 3.2.2.1-4.oe2403sp1
3.2.2.1-4.oe2403sp1
wxGTK3-3_2
SUSE:Linux Enterprise Module for Package Hub 15 SP6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxQt-3_2
SUSE:Linux Enterprise Module for Package Hub 15 SP6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxWidgets-3_2
SUSE:Linux Enterprise Module for Package Hub 15 SP6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
Show 10 moreShow less
Affected packages
PackageAffectedFixed
wxGTK3-3_2
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxQt-3_2
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxWidgets-3_2
SUSE:Linux Enterprise Module for Package Hub 15 SP7
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxGTK3-3_2
openSUSE:Leap 15.6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxQt-3_2
openSUSE:Leap 15.6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxWidgets-3_2
openSUSE:Leap 15.6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxWidgets-3_2-nostl
openSUSE:Leap 15.6
before 3.1.5-150400.3.10.1
3.1.5-150400.3.10.1
wxwidgets3.2
Ubuntu:24.04:LTS
All versions, plus listed versions
3.2.2+dfsg-43.2.4+dfsg-1ubuntu13.2.4+dfsg-1ubuntu23.2.4+dfsg-2ubuntu13.2.4+dfsg-33.2.4+dfsg-43.2.4+dfsg-4build1
None known
wxwidgets3.2
Ubuntu:25.10
All versions, plus listed versions
3.2.6+dfsg-2ubuntu13.2.8+dfsg-13.2.8+dfsg-2
None known
wxWidgets-3_2
openSUSE:Tumbleweed
before 3.2.8-4.1
3.2.8-4.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-58249 is a low vulnerability (CVSS 3.7) in Wxwidgets, published April 16, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 44th percentile. Fixed in wxwidgets3.2 3.2.7+dfsg-1.

References

Show 14 moreShow less
MoveEnter Open