Every CVE Search/ Get API key

CVE-2024-6238

pgAdmin 4 Installation Directory permission issue

7.4 High

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.25%Up 0.2 points since Jun 26, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.4

pgAdmin 4 Installation Directory permission issue

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.

Record
CVE-2024-6238
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-276
Updated
2026-11-02
EUVDEUVD-2024-47366 7.4

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.

Record
EUVD-2024-47366
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-783m-7jjf-pmgr 7.4

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers...

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.

Record
GHSA-783m-7jjf-pmgr
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Weakness
CWE-276
Updated
2026-11-02
NVD 7.4

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.

Record
CVE-2024-6238
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-276
Updated
2026-11-02
OSV 7.4

pgAdmin 4 Installation Directory permission issue

pgAdmin <= 8.8 has an installation Directory permission issue. Because of this issue, attackers can gain unauthorised access to the installation directory on the Debian or RHEL 8 platforms.

Record
CVE-2024-6238
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Updated
2026-11-02
OSVopenSUSE-SU-2025:14983-1 No score

pgadmin4-9.2-1.1 on GA media

These are all security issues fixed in the pgadmin4-9.2-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14983-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pgadmin4
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 9.2-1.1
9.2-1.1

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-6238 is a high vulnerability (CVSS 7.4) in Pgadmin 4, published June 25, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.25%, the 15th percentile. No source names a fixed version.

References

Show 4 moreShow less
MoveEnter Open