CVE-2024-6281
Path Traversal in parisneo/lollms
CVE-2024-6281 is a high vulnerability (CVSS 7.3) in Parisneo Lollms, published July 20, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 18th percentile. Fixed in lollms 9.5.1.
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.3
Path Traversal in parisneo/lollms
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
- Record
CVE-2024-6281- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2024-2301
7.3
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
- Record
EUVD-2024-2301- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-8mrm-r7h3-c3hj
7.0
LoLLMS vulnerable to Expected Behavior Violation
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
- Record
GHSA-8mrm-r7h3-c3hj- CVSS 4.0
- 7.0 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-22, CWE-440
- Updated
- 2026-11-02
NVD
7.3
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
- Record
CVE-2024-6281- CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-8mrm-r7h3-c3hj
7.0
LoLLMS vulnerable to Expected Behavior Violation
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
- Record
GHSA-8mrm-r7h3-c3hj- CVSS 4.0
- 7.0 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Weakness
- CWE-22, CWE-440
- Updated
- 2026-11-02
OSVPYSEC-2026-1587
7.0
LoLLMS vulnerable to Expected Behavior Violation
A path traversal vulnerability exists in the apply_settings function of parisneo/lollms versions prior to 9.5.1. The sanitize_path function does not adequately secure the discussion_db_name parameter, allowing attackers to manipulate the path and potentially write to important system folders.
- Record
PYSEC-2026-1587- CVSS 4.0
- 7.0 High
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 7.3 High
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
lollmsPyPI |
before 9.5.1 | 9.5.1 |
lollmsPyPI |
before 9.5.1, plus listed versions 1.1.101.1.111.1.121.1.131.1.14 Show 45 moreShow less1.1.151.1.161.1.171.1.181.1.191.1.201.1.211.1.221.1.251.1.261.1.271.1.281.1.291.1.31.1.301.1.311.1.321.1.331.1.341.1.351.1.361.1.371.1.381.1.451.1.461.1.471.1.481.1.491.1.51.1.501.1.511.1.521.1.531.1.551.1.561.1.571.1.581.1.591.1.61.1.601.1.611.1.621.1.631.1.641.1.65 |
9.5.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-02 | created | CVE List, EUVD, GitHub Advisories, NVD, OSV |
References
Left out here: 214 versions. The JSON record has them.