Every CVE Search/ Get API key

CVE-2024-6782

Calibre Remote Code Execution

9.8 CriticalPublic exploitFix available

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

84.1%Up 84.1 points since Aug 6, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.8

Calibre Remote Code Execution

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
CVE-2024-6782
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
EUVDEUVD-2024-47814 9.8

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
EUVD-2024-47814
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-g8v6-86f6-jj9q 9.8

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve...

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
GHSA-g8v6-86f6-jj9q
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
NVD 9.8

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
CVE-2024-6782
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
OSV 9.8

Calibre Remote Code Execution

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
CVE-2024-6782
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-863
Updated
2026-11-02
OSVDEBIAN-CVE-2024-6782 9.8

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
DEBIAN-CVE-2024-6782
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-6782 9.8

Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution.

Record
UBUNTU-CVE-2024-6782
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2025-0049 No score

Updated calibre packages fix security vulnerabilities

link_to_local_path in ebooks/conversion/plugins/html_input.py in calibre before 6.19.0 can, by default, add resources outside of the document root. (CVE-2023-46303) Path traversal in Calibre <= 7.14.0 allow unauthenticated attackers to achieve arbitrary file read. (CVE-2024-6781) Improper access control in Calibre 6.9.0 ~ 7.14.0 allow unauthenticated attackers to achieve remote code execution. (CVE-2024-6782) Unsanitized user-input in Calibre <= 7.15.0 allow attackers to perform reflected cross-site scripting. (CVE-2024-7008) Unsanitized user-input in Calibre <= 7.15.0 allow users with permissions to perform full-text searches to achieve SQL injection on the SQLite database. (CVE-2024-7009)

Record
MGASA-2025-0049
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
calibre
Debian:12
before 6.13.0+repack-2+deb12u4, plus listed versions
6.13.0+repack-26.13.0+repack-2+deb12u16.13.0+repack-2+deb12u26.13.0+repack-2+deb12u3
6.13.0+repack-2+deb12u4
calibre
Debian:13
before 7.16.0+ds-1
7.16.0+ds-1
calibre
Debian:14
before 7.16.0+ds-1
7.16.0+ds-1
calibre
Mageia:9
From an advisory covering 5 CVEs
before 6.17.0-1.1.mga9
6.17.0-1.1.mga9
calibre
Ubuntu:16.04:LTS
All versions, plus listed versions
2.33.0+dfsg-1build12.38.0+dfsg-12.45.0+dfsg-12.45.0+dfsg-1build12.48.0+dfsg-1
Show 4 moreShow less
2.48.0+dfsg-1build12.54.0+dfsg-12.55.0+dfsg-12.55.0+dfsg-1ubuntu0.2
None known
calibre
Ubuntu:18.04:LTS
All versions, plus listed versions
3.7.0+dfsg-23.7.0+dfsg-2build13.12.0+dfsg-13.13.0+dfsg-13.14.0+dfsg-1
Show 10 moreShow less
3.15.0.1+dfsg-13.16.0+dfsg-13.16.0+dfsg-1build13.17.0+dfsg-13.17.0+dfsg-23.18.0+dfsg-1build13.19.0+dfsg-13.20.0+dfsg-13.21.0+dfsg-13.21.0+dfsg-1build1
None known
calibre
Ubuntu:20.04:LTS
All versions, plus listed versions
3.46.0+dfsg-14.2.0+dfsg-24.3.0+dfsg-14.3.0+dfsg-24.4.0+dfsg-1
Show 14 moreShow less
4.5.0+dfsg-14.5.0+dfsg-24.5.0+dfsg-34.6.0+dfsg-14.7.0+dfsg-14.99.3+dfsg-24.99.4+dfsg-14.99.4+dfsg-1build14.99.4+dfsg+really4.10.0+py3-24.99.4+dfsg+really4.11.2-14.99.4+dfsg+really4.11.2-1build14.99.4+dfsg+really4.12.0-14.99.4+dfsg+really4.12.0-1build14.99.4+dfsg+really4.12.0-1ubuntu1
None known
calibre
Ubuntu:22.04:LTS
All versions, plus listed versions
5.25.0+dfsg-25.33.2+dfsg-15.34.0+dfsg-15.35.0+dfsg-1ubuntu25.37.0+dfsg-15.37.0+dfsg-1build1
None known
calibre
Ubuntu:24.04:LTS
All versions, plus listed versions
6.24.0+ds-16.29.0+ds-17.0.0+ds-17.1.0+ds-17.1.0+ds-2
Show 9 moreShow less
7.2.0+ds-17.2.0+ds-1build17.3.0+ds-17.4.0+ds-17.5.1+ds-17.5.1+ds-27.5.1+ds-37.6.0+ds-17.6.0+ds-1build1
None known
calibre
Ubuntu:26.04:LTS
All versions, plus listed versions
8.8.0+ds-3build18.13.0+ds+~0.10.5-38.14.0+ds+~0.10.5-18.15.0+ds+~0.10.5-18.16.0+ds+~0.10.5-2
Show 4 moreShow less
8.16.2+ds+~0.10.5-18.16.2+ds+~0.10.5-28.16.2+ds+~0.10.5-39.2.1+ds+~0.10.5-2build1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitCalibre Python Code Injection (CVE-2024-6782)2024-07-31
PoC in GitHubzangjiahe/CVE-2024-67822024-08-06
PoC in GitHubjdpsl/CVE-2024-67822024-08-09
PoC in GitHub0xB0y426/CVE-2024-6782-PoC2024-09-15
PoC in GitHubNketiahGodfred/CVE-2024-67822024-12-07
NucleiCalibre <= 7.14.0 Remote Code Execution

History

History
RecordedChangedSources
affected, exploits, facts
aliases, products, publishedEUVD
first indexedCVE List, GitHub Advisories, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-6782 is a critical vulnerability (CVSS 9.8) in Calibre, published August 6, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 84.1%, the 99th percentile. Fixed in calibre 6.13.0+repack-2+deb12u4.

References

Show 6 moreShow less
MoveEnter Open