Every CVE Search/ Get API key

CVE-2024-7954

SPIP porte_plume Plugin Arbitrary PHP Execution

9.8 CriticalPublic exploitFix available

CVE-2024-7954 is a critical vulnerability (CVSS 9.8) in Spip, published August 23, 2024. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 90.1%, the 99th percentile. Fixed in spip 4.3.0+dfsg-1.

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

90.1%Up 90.0 points since Aug 24, 2024
90%50%10%1%

What each source reports

CVE List Score used 9.8

SPIP porte_plume Plugin Arbitrary PHP Execution

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
CVE-2024-7954
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-95, CWE-1286
Updated
2026-11-02
EUVDEUVD-2024-48791 9.8

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
EUVD-2024-48791
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-42mv-3h37-wfh9 9.8

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an...

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
GHSA-42mv-3h37-wfh9
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-95, CWE-284
Updated
2026-11-02
NVD 9.8

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
CVE-2024-7954
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-95, CWE-1286
Updated
2026-11-02
OSVDEBIAN-CVE-2024-7954 9.8

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
DEBIAN-CVE-2024-7954
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2024-7954 9.8

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
UBUNTU-CVE-2024-7954
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Record
CVE-2024-7954
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
spip
Debian:13
before 4.3.0+dfsg-1
4.3.0+dfsg-1
spip
Debian:14
before 4.3.0+dfsg-1
4.3.0+dfsg-1
spip
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
3.0.20-13.0.21-13.0.21-1ubuntu13.0.21-1ubuntu1+esm1
None known
spip
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.1.4-33.1.4-4~deb9u3build0.18.04.13.1.4-4~deb9u5build0.18.04.13.1.4-4~deb9u5ubuntu0.1~esm2
None known
spip
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
3.2.4-13.2.5-13.2.7-13.2.7-1ubuntu0.13.2.7-1ubuntu0.1+esm2
None known
spip
Ubuntu:22.04:LTS
All versions, plus listed versions
3.2.11-33.2.12-14.0.2-14.0.4-1
None known
spip
Ubuntu:24.04:LTS
All versions, plus listed versions
4.1.11+dfsg-14.1.12+dfsg-14.1.13+dfsg-14.1.15+dfsg-14.2.9+dfsg-2
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitSPIP Unauthenticated RCE via porte_plume Plugin2024-08-16
NucleiSPIP Porte Plume Plugin - Remote Code Execution
PoC in GitHub0dayan0n/RCE_CVE-2024-7954-2024-12-28
PoC in GitHubArthikw3b/RCE-CVE-2024-79542025-02-05
PoC in GitHubChocapikk/CVE-2024-79542024-08-10
PoC in GitHubShivanshKuntal/Exploitation-of-a-Remote-Code-Execution-vulnerability--CVE-2024-7954-2025-12-11
PoC in GitHubTheCyberguy-17/RCE_CVE-2024-79542024-09-23
PoC in GitHubbigb0x/CVE-2024-79542024-08-28
PoC in GitHubgh-ost00/CVE-2024-7954-RCE2024-09-01
PoC in GitHubr0otk3r/CVE-2024-79542025-07-08
PoC in GitHubzxj-hub/CVE-2024-7954POC2024-12-20

History

History
WhenChangedSources
2026-11-02createdCVE List, EUVD, GitHub Advisories, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

References

MoveEnter Open