Every CVE Search/ Get API key

CVE-2024-9101

phpLDAPadmin: Reflected Cross-Site Scripting in entry_chooser.php

2.1 LowFix available

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
Active

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.50%Up 0.5 points since Dec 20, 2024
90%50%10%1%

What each source reports

CVE List Score used 2.1

phpLDAPadmin: Reflected Cross-Site Scripting in entry_chooser.php

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
CVE-2024-9101
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2024-50428 2.1

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
EUVD-2024-50428
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-6mpf-h5jc-fvrw 2.1

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin ...

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
GHSA-6mpf-h5jc-fvrw
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-79
Updated
2026-11-02
NVD 2.1

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
CVE-2024-9101
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-79
Updated
2026-11-02
OSV 2.1

phpLDAPadmin: Reflected Cross-Site Scripting in entry_chooser.php

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
CVE-2024-9101
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L
Weakness
CWE-79
Updated
2026-11-02
OSVDEBIAN-CVE-2024-9101 2.1

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
DEBIAN-CVE-2024-9101
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Updated
2026-11-02
OSVUBUNTU-CVE-2024-9101 2.1

A reflected cross-site scripting (XSS) vulnerability in the 'Entry Chooser' of phpLDAPadmin (version 1.2.1 through the latest version, 1.2.6.7) allows attackers to execute arbitrary JavaScript in the user's browser via the 'element' parameter, which is unsafely passed to the JavaScript 'eval' function. However, exploitation is limited to specific conditions where 'opener' is correctly set.

Record
UBUNTU-CVE-2024-9101
CVSS 4.0
2.1 LowCVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpldapadmin
Debian:12
All versions, plus listed versions
1.2.6.3-0.31.2.6.3-0.3+deb12u11.2.6.6-11.2.6.6-21.2.6.7-1
Show 5 moreShow less
1.2.6.7-21.2.6.7-2~bpo12+11.2.6.7-31.2.6.7-3~bpo12+11.2.6.7-4
None known
phpldapadmin
Debian:13
before 1.2.6.7-4
1.2.6.7-4
phpldapadmin
Debian:14
before 1.2.6.7-4
1.2.6.7-4
phpldapadmin
Ubuntu:16.04:LTS
All versions, plus listed versions
1.2.2-5.21.2.2-5.2ubuntu11.2.2-5.2ubuntu21.2.2-5.2ubuntu2.1
None known
phpldapadmin
Ubuntu:18.04:LTS
All versions, plus listed versions
1.2.2-6ubuntu11.2.2-6ubuntu1.1
None known
phpldapadmin
Ubuntu:20.04:LTS
All versions, plus listed versions
1.2.2-6.1ubuntu11.2.2-6.2ubuntu11.2.2-6.3
None known
phpldapadmin
Ubuntu:22.04:LTS
All versions, plus listed versions
1.2.2-6.31.2.6.3-0.2
None known
phpldapadmin
Ubuntu:24.04:LTS
All versions, plus listed versions
1.2.6.3-0.31.2.6.6-21.2.6.7-1
None known
phpldapadmin
Ubuntu:25.10
All versions, plus listed versions
1.2.6.7-4
None known
phpldapadmin
Ubuntu:26.10
All versions, plus listed versions
1.2.6.7-4
None known
phpldapadmin
Ubuntu:26.04:LTS
All versions, plus listed versions
1.2.6.7-4
None known

History

History
RecordedChangedSources
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2024-9101 is a low vulnerability (CVSS 2.1) in Phpldapadmin, published December 19, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.50%, the 42nd percentile. Fixed in phpldapadmin 1.2.6.7-4.

References

Show 6 moreShow less
MoveEnter Open