CVE-2025-0312
NULL Pointer Dereference in ollama/ollama
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
NULL Pointer Dereference in ollama/ollama
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
- Record
CVE-2025-0312- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
EUVDEUVD-2025-6816
7.5
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
- Record
EUVD-2025-6816- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-p2wh-w96x-w232
7.5
Ollama Denial of Service (DoS) via Null Pointer Dereference
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
- Record
GHSA-p2wh-w96x-w232- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
NVD
7.5
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
- Record
CVE-2025-0312- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSV
7.5
NULL Pointer Dereference in ollama/ollama
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
- Record
CVE-2025-0312- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSVGHSA-p2wh-w96x-w232
7.5
Ollama Denial of Service (DoS) via Null Pointer Dereference
A vulnerability in ollama/ollama versions <=0.3.14 allows a malicious user to create a customized GGUF model file that, when uploaded and created on the Ollama server, can cause a crash due to an unchecked null pointer dereference. This can lead to a Denial of Service (DoS) attack via remote network.
- Record
GHSA-p2wh-w96x-w232- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-476
- Updated
- 2026-11-02
OSVGO-2025-3582 No score
Ollama Denial of Service (DoS) via Null Pointer Dereference in github.com/ollama/ollama
Ollama Denial of Service (DoS) via Null Pointer Dereference in github.com/ollama/ollama
- Record
GO-2025-3582- Updated
- 2026-11-02
OSVopenSUSE-SU-2025:14970-1 No score
govulncheck-vulndb-0.0.20250402T160203-1.1 on GA media
These are all security issues fixed in the govulncheck-vulndb-0.0.20250402T160203-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:14970-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
github.com/ollama/ollamaGo |
through 0.3.14 | None known |
github.com/ollama/ollamaGo |
All versions | None known |
govulncheck-vulndbopenSUSE:Tumbleweed From an advisory covering 6 CVEs |
before 0.0.20250402T160203-1.1 | 0.0.20250402T160203-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-0312 is a high vulnerability (CVSS 7.5) in Ollama, published March 20, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.64%, the 51st percentile. No source names a fixed version.
References
huntr.com/bounties/522c87b6-a7ac-41b2-84f3-62fd58921f21
nvd.nist.gov/vuln/detail/CVE-2025-0312
github.com/advisories/GHSA-p2wh-w96x-w232
github.com/CVEProject/cvelistV5/tree/main/cves/2025/0xxx/CVE-2025-0312.json
github.com/ollama/ollama
lists.opensuse.org/archives/list/[email protected]/thread/ZBHJANMC5TN4MHLVGPYKJGT774IKFUQ3