Every CVE Search/ Get API key

CVE-2025-0520

ShowDoc < 2.8.7 Unauthenticated File Upload Remote Code Execution

9.4 CriticalFix available

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution.This issue affects ShowDoc: before 2.8.7.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
Low

Exploit likelihood

2.44%Up 2.2 points since Apr 30, 2025
90%50%10%1%

What each source reports

CVE List Score used 9.4

ShowDoc < 2.8.7 Unauthenticated File Upload Remote Code Execution

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution.This issue affects ShowDoc: before 2.8.7.

Record
CVE-2025-0520
CVSS 4.0
9.4 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
Weakness
CWE-434
Updated
2026-11-02
EUVDEUVD-2025-12661 9.4

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution.This issue affects ShowDoc: before 2.8.7.

Record
EUVD-2025-12661
CVSS 4.0
9.4 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
Updated
2026-11-02
GitHub AdvisoriesGHSA-6jmr-r7p6-f5wr 9.4

ShowDoc unrestricted file upload vulnerability

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution. This issue affects ShowDoc: before 2.8.7.

Record
GHSA-6jmr-r7p6-f5wr
CVSS 4.0
9.4 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
Weakness
CWE-434
Updated
2026-11-02
NVD 9.4

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution.This issue affects ShowDoc: before 2.8.7.

Record
CVE-2025-0520
CVSS 4.0
9.4 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Weakness
CWE-434
Updated
2026-11-02
OSV 9.4

ShowDoc < 2.8.7 Unauthenticated File Upload Remote Code Execution

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution.This issue affects ShowDoc: before 2.8.7.

Record
CVE-2025-0520
CVSS 4.0
9.4 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
Weakness
CWE-434
Updated
2026-11-02
OSVGHSA-6jmr-r7p6-f5wr 9.4

ShowDoc unrestricted file upload vulnerability

An unrestricted file upload vulnerability in ShowDoc caused by improper validation of file extension allows execution of arbitrary PHP, leading to remote code execution. This issue affects ShowDoc: before 2.8.7.

Record
GHSA-6jmr-r7p6-f5wr
CVSS 4.0
9.4 CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
Weakness
CWE-434
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
showdoc/showdoc
Packagist
before 2.8.7
2.8.7
showdoc/showdoc
Packagist
before 2.8.7, plus listed versions
v1.0.0v1.0.1v1.0.2v1.0.3v1.0.4
Show 45 moreShow less
v1.0.5v1.1.0v1.1.1v1.1.3v1.1.4v1.1.5v1.2.0v1.2.1v1.2.2v1.2.3v1.2.4v1.2.5v1.2.6v1.3.0v1.3.1v1.3.3v1.3.4v1.3.5v1.3.6v1.3.7v1.3.8v1.4.0v1.4.1v1.4.2v1.4.3v1.4.4v1.4.5v1.4.6v1.4.7v1.5.0v1.5.1v1.5.2v1.5.3v1.6.0v1.6.1v1.6.2v1.7.0v1.7.1v1.7.2v1.8.0v1.8.1v1.8.2v1.8.3v1.8.4v1.8.5
2.8.7

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
NucleiShowDoc - Remote Code Execution

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, Nuclei, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-0520 is a critical vulnerability (CVSS 9.4) in Showdoc, published April 29, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.44%, the 84th percentile. Fixed in showdoc/showdoc 2.8.7.

References

This page doesn't list everything

Left out here: 57 versions. The JSON record has them.

MoveEnter Open