CVE-2025-12819
Untrusted search path in auth_query connection in PgBouncer
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
Untrusted search path in auth_query connection in PgBouncer
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
CVE-2025-12819- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
EUVDEUVD-2025-201089
7.5
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
EUVD-2025-201089- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-qpxx-2fwx-f5qj
7.5
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.0 allows an...
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.0 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
GHSA-qpxx-2fwx-f5qj- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
NVD
7.5
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
CVE-2025-12819- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-426
- Updated
- 2026-11-02
OSVALPINE-CVE-2025-12819
8.1
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
ALPINE-CVE-2025-12819- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
8.1
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
CVE-2025-12819- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 5 moreShow less
OSVDEBIAN-CVE-2025-12819
8.1
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
DEBIAN-CVE-2025-12819- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-12819
7.5
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
UBUNTU-CVE-2025-12819- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVAZL-71249 No score
CVE-2025-12819 affecting package pgbouncer for versions less than 1.25.1-1
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
AZL-71249- Updated
- 2026-11-02
OSVAZL-71438 No score
CVE-2025-12819 affecting package pgbouncer for versions less than 1.25.1-1
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
AZL-71438- Updated
- 2026-11-02
OSVBIT-pgbouncer-2025-12819 No score
Untrusted search path in auth_query connection in PgBouncer
Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.
- Record
BIT-pgbouncer-2025-12819- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pgbouncerAlpine:v3.23 |
before 1.25.1-r0 | 1.25.1-r0 |
pgbouncerAlpine:v3.24 |
before 1.25.1-r0 | 1.25.1-r0 |
pgbouncerAzure Linux:3 |
before 1.25.1-1 | 1.25.1-1 |
pgbouncerAzure Linux:2 |
before 1.25.1-1 | 1.25.1-1 |
pgbouncerBitnami |
before 1.25.1 | 1.25.1 |
pgbouncerDebian:12 |
before 1.18.0-1+deb12u1, plus listed versions 1.18.0-1 |
1.18.0-1+deb12u1 |
pgbouncerDebian:13 |
before 1.24.1-1+deb13u1, plus listed versions 1.24.1-1 |
1.24.1-1+deb13u1 |
pgbouncerDebian:14 |
before 1.25.1-1, plus listed versions 1.24.1-11.25.0-11.25.0-2 |
1.25.1-1 |
pgbouncerDebian:11 |
before 1.15.0-1+deb11u2, plus listed versions 1.15.0-11.15.0-1+deb11u1 |
1.15.0-1+deb11u2 |
pgbouncerUbuntu:16.04:LTS |
All versions, plus listed versions 1.5.5-11.6.1-11.7-1 |
None known |
Show 6 moreShow less
| Package | Affected | Fixed |
|---|---|---|
pgbouncerUbuntu:18.04:LTS |
All versions, plus listed versions 1.7.2-3build11.7.2-65-g2b8e6cf-11.8.1-11.8.1-1build1 |
None known |
pgbouncerUbuntu:20.04:LTS |
All versions, plus listed versions 1.10.0-11.10.0-1build11.11.0-11.12.0-21.12.0-3 |
None known |
pgbouncerUbuntu:22.04:LTS |
All versions, plus listed versions 1.15.0-11.16.1-1ubuntu1 |
None known |
pgbouncerUbuntu:24.04:LTS |
All versions, plus listed versions 1.20.0-11.21.0-11.22.0-11.22.0-1build11.22.0-1build31.22.0-1build4 |
None known |
pgbouncerUbuntu:25.10 |
All versions, plus listed versions 1.24.0-31.24.1-1 |
None known |
pgbouncerUbuntu:26.04:LTS |
All versions, plus listed versions 1.24.1-11.25.0-21.25.1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-12819 is a high vulnerability (CVSS 7.5) in Pgbouncer, published December 3, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 33rd percentile. Fixed in pgbouncer 1.25.1-r0.
References
pgbouncer.org/changelog.html
lists.debian.org/debian-lts-announce/2025/12/msg00033.html
nvd.nist.gov/vuln/detail/CVE-2025-12819
github.com/advisories/GHSA-qpxx-2fwx-f5qj
security.alpinelinux.org/vuln/CVE-2025-12819
security-tracker.debian.org/tracker/CVE-2025-12819
ubuntu.com/security/CVE-2025-12819
cve.org/CVERecord?id=CVE-2025-12819