Every CVE Search/ Get API key

CVE-2025-1293

HashiCorp Hermes Improperly Validates AWS ALB JWTs, which May Lead to Authentication Bypass

8.2 HighFix available

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
None

Exploit likelihood

0.35%Up 0.3 points since Feb 20, 2025
90%50%10%1%

What each source reports

CVE List Score used 8.2

HashiCorp Hermes Improperly Validates AWS ALB JWTs, which May Lead to Authentication Bypass

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Record
CVE-2025-1293
CVSS 3.1
8.2 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-1390
Updated
2026-11-02
EUVDEUVD-2025-4584 8.2

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Record
EUVD-2025-4584
CVSS 3.1
8.2 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-vxm9-8mfw-vc6g 8.2

Hermes improperly validates a JWT

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Record
GHSA-vxm9-8mfw-vc6g
CVSS 3.1
8.2 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-1390
Updated
2026-11-02
NVD 8.2

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Record
CVE-2025-1293
CVSS 3.1
8.2 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
CVSS 3.1
8.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-1390
Updated
2026-11-02
OSV 8.2

HashiCorp Hermes Improperly Validates AWS ALB JWTs, which May Lead to Authentication Bypass

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Record
CVE-2025-1293
CVSS 3.1
8.2 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-1390
Updated
2026-11-02
OSVGHSA-vxm9-8mfw-vc6g 8.2

Hermes improperly validates a JWT

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Record
GHSA-vxm9-8mfw-vc6g
CVSS 3.1
8.2 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-1390
Updated
2026-11-02
OSVGO-2025-3475 No score

Hermes improperly validates a JWT in github.com/hashicorp-forge/hermes

Hermes improperly validates a JWT in github.com/hashicorp-forge/hermes

Record
GO-2025-3475
Updated
2026-11-02
OSVopenSUSE-SU-2025:14889-1 No score

govulncheck-vulndb-0.0.20250312T181707-1.1 on GA media

These are all security issues fixed in the govulncheck-vulndb-0.0.20250312T181707-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:14889-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/hashicorp-forge/hermes
Go
before 0.5.0
0.5.0
govulncheck-vulndb
openSUSE:Tumbleweed
From an advisory covering 31 CVEs
before 0.0.20250312T181707-1.1
0.0.20250312T181707-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-1293 is a high vulnerability (CVSS 8.2) in Hashicorp Hermes, published February 20, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.35%, the 28th percentile. Fixed in github.com/hashicorp-forge/hermes 0.5.0.

References

Show 31 moreShow less
MoveEnter Open