CVE-2025-12998
Broken Authentication in extension “Modules” (modules)
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
8.2
Broken Authentication in extension “Modules” (modules)
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
- Record
CVE-2025-12998- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-287
- Updated
- 2026-11-02
EUVDEUVD-2025-124903
8.2
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
- Record
EUVD-2025-124903- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-49qv-h8pm-73pf
8.2
TYPO3 Modules Extension has Improper Authentication vulnerability
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules. This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
- Record
GHSA-49qv-h8pm-73pf- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-287
- Updated
- 2026-11-02
NVD
8.2
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
- Record
CVE-2025-12998- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
8.2
Broken Authentication in extension “Modules” (modules)
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
- Record
CVE-2025-12998- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-287
- Updated
- 2026-11-02
OSVGHSA-49qv-h8pm-73pf
8.2
TYPO3 Modules Extension has Improper Authentication vulnerability
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules. This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
- Record
GHSA-49qv-h8pm-73pf- CVSS 4.0
- 8.2 High
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N - Weakness
- CWE-287
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
codingms/modulesPackagist |
before 4.3.11 | 4.3.11 |
codingms/modulesPackagist |
5.0.0 up to 5.7.4 | 5.7.4 |
codingms/modulesPackagist |
7.0.0 up to 7.5.5 | 7.5.5 |
codingms/modulesPackagist |
6.0.0 up to 6.4.2 | 6.4.2 |
codingms/modulesPackagist |
before 4.3.11, plus listed versions 3.0.13.1.03.1.13.1.23.2.0 Show 33 moreShow less4.0.04.0.14.0.24.0.34.0.44.1.04.1.14.1.24.1.34.1.44.1.54.1.64.2.04.2.14.2.24.2.34.2.44.2.54.2.64.2.74.2.84.2.94.3.04.3.14.3.104.3.24.3.34.3.44.3.54.3.64.3.74.3.84.3.9 |
4.3.11 |
codingms/modulesPackagist |
5.0.0 up to 5.7.4, plus listed versions 5.1.05.1.15.1.25.1.35.1.4 Show 12 moreShow less5.2.05.2.15.2.25.3.05.4.05.4.15.5.05.6.05.7.05.7.15.7.25.7.3 |
5.7.4 |
codingms/modulesPackagist |
7.0.0 up to 7.5.5, plus listed versions 7.0.17.0.27.1.07.1.17.1.2 Show 17 moreShow less7.2.07.2.17.3.07.3.17.3.27.3.37.4.07.4.17.4.27.4.37.4.47.4.57.4.67.5.07.5.27.5.37.5.4 |
7.5.5 |
codingms/modulesPackagist |
6.0.0 up to 6.4.2, plus listed versions 6.0.16.1.06.1.16.1.26.2.0 Show 13 moreShow less6.2.16.2.26.2.36.2.46.2.56.2.66.2.76.2.86.2.96.3.06.3.16.4.06.4.1 |
6.4.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-12998 is a high vulnerability (CVSS 8.2) in Typo3 Extension "modules", published November 12, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.36%, the 29th percentile. Fixed in codingms/modules 4.3.11.
References
typo3.org/security/advisory/typo3-ext-sa-2025-015
nvd.nist.gov/vuln/detail/CVE-2025-12998
gitlab.com/codingms/typo3-public/modules/-/commit/7fe0f9fbf2ea81343e4e8ede5a34c450c58d8ce1
github.com/advisories/GHSA-49qv-h8pm-73pf
packagist.org
github.com/CVEProject/cvelistV5/tree/main/cves/2025/12xxx/CVE-2025-12998.json
gitlab.com/codingms/typo3-public/modules