CVE-2025-13654
CVE-2025-13654
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
7.5
CVE-2025-13654
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
CVE-2025-13654- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
EUVDEUVD-2025-201406
7.5
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
EUVD-2025-201406- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9fqr-94hm-qxr9
7.5
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management...
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
GHSA-9fqr-94hm-qxr9- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
NVD
7.5
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
CVE-2025-13654- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
7.5
CVE-2025-13654
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
CVE-2025-13654- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2025-13654
7.5
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
DEBIAN-CVE-2025-13654- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2025-13654
7.5
A stack buffer overflow vulnerability exists in the buffer_get function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read.
- Record
UBUNTU-CVE-2025-13654- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2025:15835-1 No score
duc-1.4.6-1.1 on GA media
These are all security issues fixed in the duc-1.4.6-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2025:15835-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ducDebian:12 |
All versions, plus listed versions 1.4.4-11.4.5-11.4.6-1 |
None known |
ducDebian:13 |
All versions, plus listed versions 1.4.5-11.4.6-1 |
None known |
ducDebian:14 |
before 1.4.6-1, plus listed versions 1.4.5-1 |
1.4.6-1 |
ducUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.3-11.3.3-1build1 |
None known |
ducUbuntu:18.04:LTS |
All versions, plus listed versions 1.4.3-21.4.3-3 |
None known |
ducUbuntu:20.04:LTS |
All versions, plus listed versions 1.4.3-6 |
None known |
ducUbuntu:22.04:LTS |
All versions, plus listed versions 1.4.4-1 |
None known |
ducUbuntu:24.04:LTS |
All versions, plus listed versions 1.4.5-11.4.5-1build11.4.5-1build2 |
None known |
ducUbuntu:25.10 |
All versions, plus listed versions 1.4.5-1build2 |
None known |
ducUbuntu:26.04:LTS |
All versions, plus listed versions 1.4.5-1build21.4.6-1 |
None known |
ducopenSUSE:Tumbleweed |
before 1.4.6-1.1 | 1.4.6-1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-13654 is a high vulnerability (CVSS 7.5) in Duc, published December 5, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 60th percentile. Fixed in duc 1.4.6-1.