Every CVE Search/ Get API key

CVE-2025-13763

Libopensc: opensc: multiple uses of uninitialized variable

5.7 MediumFix available

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Attack profile

How easy it is to exploit

Attack vector
Physical
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

0.27%Up 0.2 points since Apr 24, 2026
90%50%10%1%

What each source reports

CVE List Score used 5.7

Libopensc: opensc: multiple uses of uninitialized variable

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Record
CVE-2025-13763
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-457
Updated
2026-11-06
EUVDEUVD-2025-209564 5.7

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Record
EUVD-2025-209564
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-06
NVD 5.7

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Record
CVE-2025-13763
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Weakness
CWE-457
Updated
2026-11-06
OSVBELL-CVE-2025-13763 5.7
Record
BELL-CVE-2025-13763
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSV 5.7

Libopensc: opensc: multiple uses of uninitialized variable

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Record
CVE-2025-13763
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-07
OSVDEBIAN-CVE-2025-13763 5.7

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Record
DEBIAN-CVE-2025-13763
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-07
OSVUBUNTU-CVE-2025-13763 5.7

Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or application crash. An attack requires a crafted USB device or smart card that would present the system with specially crafted responses to the APDUs

Record
UBUNTU-CVE-2025-13763
CVSS 3.1
5.7 MediumCVSS:3.1/AV:P/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
Updated
2026-11-02
OSVMGASA-2026-0224 No score

Updated opensc packages fix security vulnerabilities

CVE-2025-66038 Memory corruption via improper compact-TLV length validation CVE-2025-66215 Stack-buffer-overflow with physical access via crafted smart card or USB device CVE-2025-49010 Stack-buffer-overflow via crafted smart card or USB device responses CVE-2025-66037 Out-of-bounds read via crafted input CVE-2025-13763 Several uses of potentially uninitialized memory detected by fuzzers

Record
MGASA-2026-0224
Updated
2026-11-02
OSVopenSUSE-SU-2026:10475-1 No score

opensc-0.27.1-1.1 on GA media

These are all security issues fixed in the opensc-0.27.1-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2026:10475-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opensc
Alpaquita:23
0.22.0-r4 up to 0.27.1-r0
0.27.1-r0
opensc
Alpaquita:25
0.26.0-r0 up to 0.27.1-r0
0.27.1-r0
opensc
Alpaquita:stream
0.22.0-r4 up to 0.27.1-r0
0.27.1-r0
opensc
Debian:12
All versions, plus listed versions
0.23.0-0.30.23.0-0.3+deb12u10.23.0-0.3+deb12u20.23.0-10.23.0-2
Show 14 moreShow less
0.24.0~rc1-10.25.0~rc1-10.25.1-10.25.1-20.25.1-2.10.26.0-10.26.1-10.26.1-20.26.1-30.27.0~rc1-10.27.0~rc2-10.27.1-10.27.1-20.27.1-3
None known
opensc
Debian:13
All versions, plus listed versions
0.26.1-20.26.1-30.27.0~rc1-10.27.0~rc2-10.27.1-10.27.1-20.27.1-3
None known
opensc
Debian:14
before 0.27.0~rc1-1, plus listed versions
0.26.1-20.26.1-3
0.27.0~rc1-1
opensc
Mageia:9
From an advisory covering 5 CVEs
before 0.25.0-1.2.mga9
0.25.0-1.2.mga9
opensc
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
0.15.0-1ubuntu10.15.0-1ubuntu1+esm10.15.0-1ubuntu1+esm20.15.0-1ubuntu1+esm3
None known
opensc
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
0.17.0-10.17.0-20.17.0-2build10.17.0-30.17.0-3ubuntu0.1~esm10.17.0-3ubuntu0.1~esm20.17.0-3ubuntu0.1~esm3
None known
opensc
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
0.19.0-20.20.0-10.20.0-20.20.0-30.20.0-3ubuntu0.1~esm10.20.0-3ubuntu0.1~esm20.20.0-3ubuntu0.1~esm30.20.0-3ubuntu0.1~esm4
None known
Show 6 moreShow less
Affected packages
PackageAffectedFixed
opensc
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
0.21.0-1ubuntu10.22.0-1ubuntu20.22.0-1ubuntu2+esm10.22.0-1ubuntu2.10.22.0-1ubuntu2.1+esm1
None known
opensc
Ubuntu:Pro:24.04:LTS
All versions, plus listed versions
0.23.0-1ubuntu40.24.0~rc1-10.25.0~rc1-10.25.0~rc1-1build10.25.0~rc1-1build2
Show 4 moreShow less
0.25.0~rc1-1ubuntu0.1~esm10.25.0~rc1-1ubuntu0.10.25.0~rc1-1ubuntu0.20.25.0~rc1-1ubuntu0.2+esm1
None known
opensc
Ubuntu:25.10
All versions, plus listed versions
0.26.1-10.26.1-20.26.1-3
None known
opensc
Ubuntu:26.10
All versions, plus listed versions
0.27.0~rc1-10.27.1-20.27.1-2ubuntu10.27.1-2ubuntu2
None known
opensc
Ubuntu:26.04:LTS
All versions, plus listed versions
0.26.1-30.26.1-3ubuntu10.27.0~rc1-1
None known
opensc
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 0.27.1-1.1
0.27.1-1.1

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2025-13763 is a medium vulnerability (CVSS 5.7) in Opensc, published April 1, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 18th percentile. Fixed in opensc 0.27.1-r0.

References

Show 14 moreShow less
MoveEnter Open