CVE-2025-13828
Mautic user without privileged access to the Marketplace can install and uninstall composer packages
SummaryA non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.
ImpactA low-privileged user of the platform can install malicious code to obtain higher privileges.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
9.0
Mautic user without privileged access to the Marketplace can install and uninstall composer packages
SummaryA non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.
ImpactA low-privileged user of the platform can install malicious code to obtain higher privileges.
- Record
CVE-2025-13828- CVSS 4.0
- 9.0 Critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H - Weakness
- CWE-862
- Updated
- 2026-11-02
EUVDEUVD-2025-200275
9.0
SummaryA non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.
ImpactA low-privileged user of the platform can install malicious code to obtain higher privileges.
- Record
EUVD-2025-200275- CVSS 4.0
- 9.0 Critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-3fq7-c5m8-g86x
9.0
Mautic user without privileged access to the Marketplace can install and uninstall composer packages
Summary
A non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.
Impact
A low-privileged user of the platform can install malicious code to obtain higher privileges.
- Record
GHSA-3fq7-c5m8-g86x- CVSS 4.0
- 9.0 Critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H - Weakness
- CWE-284, CWE-862
- Updated
- 2026-11-02
NVD
9.0
SummaryA non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.
ImpactA low-privileged user of the platform can install malicious code to obtain higher privileges.
- Record
CVE-2025-13828- CVSS 4.0
- 9.0 Critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X - Weakness
- CWE-862
- Updated
- 2026-11-02
OSVGHSA-3fq7-c5m8-g86x
9.0
Mautic user without privileged access to the Marketplace can install and uninstall composer packages
Summary
A non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.
Impact
A low-privileged user of the platform can install malicious code to obtain higher privileges.
- Record
GHSA-3fq7-c5m8-g86x- CVSS 4.0
- 9.0 Critical
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H - Weakness
- CWE-284, CWE-862
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mautic/corePackagist |
4.0.0 up to 4.4.18 | 4.4.18 |
mautic/corePackagist |
5.0.0 up to 5.2.9 | 5.2.9 |
mautic/corePackagist |
6.0.0 up to 6.0.7 | 6.0.7 |
mautic/corePackagist |
4.0.0 up to 4.4.18, plus listed versions 4.0.14.0.24.1.04.1.14.1.2 Show 24 moreShow less4.2.04.2.0-rc4.2.0-rc14.2.14.2.24.3.04.3.0-beta4.3.0-rc4.3.14.4.04.4.0-beta4.4.14.4.104.4.114.4.124.4.134.4.24.4.34.4.44.4.54.4.64.4.74.4.84.4.9 |
4.4.18 |
mautic/corePackagist |
5.0.0 up to 5.2.9, plus listed versions 5.0.15.0.25.0.35.0.45.1.0 Show 10 moreShow less5.1.15.2.05.2.15.2.25.2.35.2.45.2.55.2.65.2.75.2.8 |
5.2.9 |
mautic/corePackagist |
6.0.0 up to 6.0.7, plus listed versions 6.0.16.0.26.0.36.0.46.0.56.0.6 |
6.0.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-13828 is a critical vulnerability (CVSS 9.0) in Mautic, published December 2, 2025. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.27%, the 18th percentile. Fixed in mautic/core 4.4.18.