CVE-2025-14025
Ansible-automation-platform/aap-gateway: aap-gateway: read-only personal access token (pat) bypasses write restrictions
A flaw was found in Ansible Automation Platform (AAP). Read-only scoped OAuth2 API Tokens in AAP, are enforced at the Gateway level for Gateway-specific operations. However, this vulnerability allows read-only tokens to perform write operations on backend services (e.g., Controller, Hub, EDA). If this flaw were exploited, an attacker‘s capabilities would only be limited by role based access controls (RBAC).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.5
Ansible-automation-platform/aap-gateway: aap-gateway: read-only personal access token (pat) bypasses write restrictions
A flaw was found in Ansible Automation Platform (AAP). Read-only scoped OAuth2 API Tokens in AAP, are enforced at the Gateway level for Gateway-specific operations. However, this vulnerability allows read-only tokens to perform write operations on backend services (e.g., Controller, Hub, EDA). If this flaw were exploited, an attacker‘s capabilities would only be limited by role based access controls (RBAC).
- Record
CVE-2025-14025- CVSS 3.1
- 8.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-279
- Updated
- 2026-11-02
EUVDEUVD-2026-1455
8.5
A flaw was found in Ansible Automation Platform (AAP). Read-only scoped OAuth2 API Tokens in AAP, are enforced at the Gateway level for Gateway-specific operations. However, this vulnerability allows read-only tokens to perform write operations on backend services (e.g., Controller, Hub, EDA). If this flaw were exploited, an attacker‘s capabilities would only be limited by role based access controls (RBAC).
- Record
EUVD-2026-1455- CVSS 3.1
- 8.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-3j6w-p6vm-g8hg
8.5
A flaw was found in Ansible Automation Platform (AAP). Read-only scoped OAuth2 API Tokens in AAP,...
A flaw was found in Ansible Automation Platform (AAP). Read-only scoped OAuth2 API Tokens in AAP, are enforced at the Gateway level for Gateway-specific operations. However, this vulnerability allows read-only tokens to perform write operations on backend services (e.g., Controller, Hub, EDA). If this flaw were exploited, an attacker‘s capabilities would only be limited by role based access controls (RBAC).
- Record
GHSA-3j6w-p6vm-g8hg- CVSS 3.1
- 8.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-279
- Updated
- 2026-11-02
NVD
8.5
A flaw was found in Ansible Automation Platform (AAP). Read-only scoped OAuth2 API Tokens in AAP, are enforced at the Gateway level for Gateway-specific operations. However, this vulnerability allows read-only tokens to perform write operations on backend services (e.g., Controller, Hub, EDA). If this flaw were exploited, an attacker‘s capabilities would only be limited by role based access controls (RBAC).
- Record
CVE-2025-14025- CVSS 3.1
- 8.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-279
- Updated
- 2026-11-02
OSVRHSA-2026:0360
8.5
Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.6 Product Security Update
- Record
RHSA-2026:0360- CVSS 3.1
- 8.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVRHSA-2026:0361
8.5
Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.5 Product Security Update
- Record
RHSA-2026:0361- CVSS 3.1
- 8.5 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
automation-gateway-serverRed Hat:ansible_automation_platform:2.6::el9 |
before 0:2.6.20260106-1.el9ap | 0:2.6.20260106-1.el9ap |
automation-gateway-serverRed Hat:ansible_automation_platform:2.5::el8 |
before 0:2.5.20260106-1.el8ap | 0:2.5.20260106-1.el8ap |
automation-gateway-serverRed Hat:ansible_automation_platform:2.5::el9 |
before 0:2.5.20260106-1.el9ap | 0:2.5.20260106-1.el9ap |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2025-14025 is a high vulnerability (CVSS 8.5) in Red Hat Ansible Automation Platform 2.5, published January 8, 2026. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.42%, the 36th percentile. Fixed in automation-gateway-server 0:2.6.20260106-1.el9ap.
References
access.redhat.com/articles/7136004
access.redhat.com/errata/RHSA-2026:0360
access.redhat.com/errata/RHSA-2026:0361
access.redhat.com/errata/RHSA-2026:0408
access.redhat.com/errata/RHSA-2026:0409
access.redhat.com/security/cve/CVE-2025-14025
Show 7 moreShow less
bugzilla.redhat.com/show_bug.cgi?id=2418785
nvd.nist.gov/vuln/detail/CVE-2025-14025
github.com/advisories/GHSA-3j6w-p6vm-g8hg
access.redhat.com/security/updates/classification
security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_0360.json
cve.org/CVERecord?id=CVE-2025-14025
security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_0361.json